Обзор

Web Page Maker – это очень простой инструмент для создания веб – страниц. С его помощью вы сможете создать свою страничку даже не обладая никакими знаниями HTML. Просто перетаскивайте мышкой на рабочее пространство программы изображения, текст, музыку и видео. Во время работы вы с лёгкостью можете передвигать объекты по всей странице. Web Page Maker содержит несколько высококачественных шаблонов, которые помогут вам начать работу. Также вместе с программой поставляются различные эскизы, Java - скрипты, таблицы, формы и т.д. В программу встроен ФТП – загрузчик, с помощью которого вы сможете опубликовать свой сайт в интернете.


Возможности программы

Создайте свой сайт с помощью этого профессионального, лёгкого в использованиии веб-редактора! Программа настолько проста. что Вы сможете создать в ней сайт за очень короткое время.

Основные возможности:
  • Не требуется знаний HTML и никакого опыта создания веб-страниц.
  • Перетаскивание объектов -- WYSIWYG дизайн.
  • Возможность создавать сайты со многими страницами и, одновремено, элементарно ими управлять.
  • Создание неограниченного количества сайтов.
  • Наличие шаблонов веб-сайтов.
  • Возможность использования каскадных таблиц стилей (CSS), чтобы контролировать отображение текста на вашем сайте.
  • Сотни функций: эскизы, эффекты при наведении мыши, сценарии Java, таблицы, формы, фреймы и так далее.
  • Возможность опубликовать все страницы вашего сайта одновременно, благодаря встроенной функции публикации.
  • Совместимость со всеми видами браузеров, включая Netscape, Mozilla, Opera, а не только Internet Explorer.


Установка

Установка Web Page Maker

Придерживайтесь следующих шагов при установке программы:

    1. Дважды щёлкните по значку инсталлятора Web Page Maker.
    2. Следуйте инструкциям, показанным на экране.

Чтобы удалить программу, следуйте этим инструкциям:

В меню «Пуск» выберите «Панель управления», затем «Установка и удаление программ». Найдите в вписке «Web Page Maker» и нажмите Удалить.


Системные требования

Для нормальной работы программы необходимы следующие условия:

  • Intel Pentium совместимый процессор с частотой 400 Мгц и выше
  • Windows 98, Windows 2000, Windows XP, или Windows .NET Сервер 2003
  • Минимум 64 Мб оперативной памяти (RAM). Рекомендуется 256 Мб
  • 100 Мб свободного дискового пространства
  • 16-ти битный монитор с разрешением 1024 x 768 точек или выше
  • Internet Explorer 5.0 или 6.0 (рекомендуется).


Окна и панели инструментов

Этот раздел вкратце описывает некоторые элементы рабочего пространства Web Page Maker.

Панель инструментов (Toolbar) содержит кнопки для вставки в ваш документ различных типов объектов: изображений, текста, навигационных панелей и т.п. Например, вы можете вставить рисунок, нажав на соответствующую кнопку в панели инструментов. По вашему желанию можно также вставлять объекты при помощи меню Вставить в Панели инструментов.

Рабочее окно отображает текущий документ, над которым вы работаете. Это пространство, на которое вы можете перетаскивать (Drag and Drop) различные объекты.

Панель сайта позволяет вам управлять страницами на вашем сайте. Для сткрытия или отображения панели нажмите F8.

На Вкладке страниц есть кнопки для добавления, клонирования (дублирования) и удаления страниц сайта. Здесь в виде списка показаны все страницы вашего сайта.

Перемещайтесь от страницы к странице, выбирая соответствующие в списке. Для переименования выберите страницу, нажмите правую кнопку мыши и щёлкните «Переименовать», затем введите новое имя. При опубликовании проекта в сети ваши странички будут носить то же имя, что и в панели сайта.

По умолчанию имя первой страницы проекта – index. При опубликовании будет создан файл index.html. Запомните: ваша домашняя страничка должна начинаться с index.

На Вкладке элементов отображаются все компоненты, входящие в текущую страницу списка.


Обзор меню

Этот раздел справки вкратце описывает функции меню Web Page Maker.

Меню Файл

Рис. 2

содержит стандартные элементы, такие как:

  • создать (новую страницу);
  • открыть;
  • сохранить.

Также здесь находятся различные команды для работы с документом или связанные с его просмотром (Опубликовать…, Просмотр в браузере и т.д.

Меню Правка

Рис. 3

содержит такие элементы, как:

  • вырезать;
  • копировать;
  • вставить;
  • вернуть;
  • отменить и т.д. (рис. 3).

Блокировка элемента:

Если вы уже настроили и расположили на странице элемент так, как вам нужно, то вы можете заблокировать его, чтобы предотвратить его случайное смещение с заданного места. Для этого в программе реализована возможность блокирования элементов .

  1. Выберите элемент, который вы хотите заблокировать.
  2. Выберите пункт меню Правка > Блокировать.

Отображение сетки:

Эта команда поможет вам правильно расположить элементы по-вертикали и по-горизонтали. Включается и выключается она командой Показать сетку .

Привязать к сетке:

С помощью этой команды вы сможете выстроить элементы на странице по чётко заданным параметрам (в пикселях). Значение по умолчанию равно 10 пикселей, так что вы сможете передвигать элемент по странице чётко на 10, 20, 30 и т.д. единиц. В Параметрах сетки вы можете изменить это значение .

Показывать указатель границ:

Указатель границ показывает контрольный каркас вашей страницы (её крайние границы), он может быть полезен для позиционирования элементов в зависимости от разрешения экрана .

Меню Страница

Даёт вам возможности добавления, клонирования (дублирования), удаления страниц сайта. Здесь вы также можете задать свойства вашей странички .

Добавить новую страницу Добавляет пустую страницу в конец документа

Клонировать страницу Копирует текущую страницу.

Удалить страницу Удаляет текущую страницу из документа.

Меню Вставка

является алтернативой панели инструментов для вставки элементов в ваш документ.

Меню Формат

позволяет вам изменять свойства выбранного элемента страницы.

Меню Оформление

используется для изменения свойств документа, для установки позиционирования элементов и для группирования двух и более объектов.

Вынести на передний план Передвигает выбранный объект на одну позицию вперёд.

Переместить на задний план Передвигает выбранный объект на одну позицию назад.

Все на передний план Передвигает выбранный объект поверх всех объектов.

Все на задний план Передвигает выбранный объект назад относительно всех объектов.

Разместив два или более объектов на веб-странице, вы можете использовать для их упорядочивания команду Выровнять . Для этого доступны такие команды:

Выровнять по левому краю Выравнивает выбранные элементы по левой стороне.

Выровнять по правому краю Выравнивает выбранные элементы по правой стороне.

Выровнять по верхнему краю Выравнивает выбранные элементы по верху.

Выровнять по нижнему краю Выравнивает выбранные элементы по низу.

Группировать Преобразует временный элемент группы в основной.

Разгруппировать Разбивает элемент группы на элементы её членов.

Меню Справка

содержит следующие команды:

Справка Вызывает документ, который вы сейчас читаете :).

Сведения... Показывает версию приложения.


Расположение элементов страницы

Web Page Maker позволяет вам перетаскивать объекты странички на любое место, куда вы захотите. После добавления объекта просто переместите его куда вам нужно и отпустите кнопку мыши. Можно использовать стрелки на клавиатуре для точного определения места объекта.

Для того, чтобы перетащить объект:

1. Щёлкните на нём левой кнопкой мыши.

2. Переместите, куда вам необходимо.

3. Отпустите кнопку.

Для позиционирования объекта с помощью стрелок клавиатуры:

1. Кликните по соответствующему элементу.

2. Воспользуйтесь клавишами Ctrl+стрелки для его перемещения.

Отображение сетки

Вы можете включить отображение линий сетки на веб-странице, это поможет вам более точно установить объект. Сетка отображается только в рабочем окне; на настоящей веб-странице она не видна.

Для отображения сетки, выберите или снимите пункт Показывать сетку в меню Правка .

Привязывание к сетке

При активации этой функции, объекты будут перемещаться строго в рамках размера клеточек указанной сетки. Это поможет вам более точно установить объект на веб-странице.

Чтобы включить привязывание к сетке, выберите в меню Правка -> Привязать к сетке .

Показывать указатель границ

Указатель границ показывает контрольный профиль (target outline), он может использоваться для позиционирования объектов в зависимости от разрешения экрана. Указатель границ отображается только в рабочем окне; на настоящей веб-странице он не виден.

Для отображения указателя страниц отметьте соответствующий пункт в меню Справка .


Управление объектами

Управление объектами страницы

Здесь вы узнаете как выделить, удалить, или копировать любой из объектов на вашей страничке.

Выделение объекта страницы

Для того, чтобы вырезать, копировать, удалить, дублировать, или изменить элемент страницы, вы должны сначала его выделить. Границы выделенных объектов подсвечиваются розовым цветом.

  • Для выделения одного объекта просто щёлкните на нём.
  • Для выделения нескольких элементов, удерживайте нажатой клавишу Shift , и жмите на те объекты, которые вы хотите выделить.

Примечание: Вы можете выбрать несколько объектов, выделяя мышкой прямоугольник вокруг них.

Удаление объекта

Для удаления любого объекта:

1. Кликните на нём для выделения.

2. Выберите команду Удалить из меню Правкалибо воспользуйтесь кнопкой Delete на клавиатуре.

Копирование объекта

Для копирования объектов страницы:

1. Кликните на любом из них для выделения.

2. Выберите команду Копировать из меню Правка либо используйте комбинацию клавиш Ctrl+C .

3. Кликните правой кнопкой на нужном месте рабочего окна.

4. Выберите команду Вставить из меню Правкалибо используйте комбинацию клавиш Ctrl+V .

Для копирования объекта с одной страницы на другую:

1. Кликните на необходимом объекте на первой странице.

2. Выберите команду Копировать из меню Правка либо используйте комбинацию клавиш Ctrl+C .

3. Переключитесь на другую страницу выбрав её имя в "Панели сайтов " в правой части экрана.

4. Кликните правой кнопкой на нужном месте второй страницы.

5. Выберите команду Вставить из меню Правкалибо используйте комбинацию клавиш Ctrl+V .


Изменение размеров

Изменение размеров объектов

С помощью Web Page Maker легко изменить размеры объекта на странице. Просто выберите его и растяните до необходимого размера, используя специальные манипуляторы .

Для изменения размера объекта на странице:

1. Выберите необходимый объект.

2. Переместите указатель мыши до границы или угла объекта, пока он не примет форму в виде двунаправленной стрелки.

3. Кликните по специальному манипулятору, удерживая нажатой левую кнопку мыши измените размер объекта до необходимых размеров.

Примечание: для сохранения пропорций размера, поставьте курсор на угол объекта и растяните до необходимого размера.

Для изменения размера объекта на странице при помощи клавиатуры:

1. Выберите необходимый объект.

2. Используйте комбинации клавиш Shift+стрелки и растяните до необходимого размера.

Для получения точного размера объекта на странице:

1. Выберите необходимый объект.

2. Кликните правой кнопкой -> Свойства , появится диалог свойств.

3. На вкладке Общие установите точный размер.


Выравнивание

Выравнивание объектов

Когда вы разместили на странице два или более объектов, вы можете воспользоваться командой Выровнять , для их автоматического выравнивания.

Чтобы выровнять два или более объектов:

1. Выберите необходимые объекты. (О том, как это сделать, рассказано выше.)

2. Укажите желаемое выравнивание (Выровнять по левому краю, ... по правому краю, ... по верхнему краю, или ... по нижнему краю) из пункта меню Оформление .


Управление слоями

Управление слоями объектов

Web Page Maker позволяет вам перекрывать изображения и текст, чтобы получился более изысканный дизайн веб-страниц.

  • Вынести на передний план

Используйте эту команду для отображения объекта из группы многослойных объектов, чтобы вынести его на один слой вперёд.

Чтобы вынести элемент на предний план:

1. Кликните на объекте.

2. Выберите Вынести на передний план из меню Оформление .

  • На задний план

Используйте эту команду для отображения объекта из группы многослойных объектов, чтобы вынести его на один слой назад.

Чтобы вынести элемент на задний план:

1. Кликните на объекте.

2. Выберите Переместить на задний план из меню Оформление.

  • Вынести наверх

Используйте эту команду для отображения объекта из группы многослойных объектов, чтобы вынести его на САМЫЙ верхний слой.

Чтобы вынести на самый верхний слой:

1. Кликните на объекте.

2. Выберите Вынести наверх в меню Оформление .

  • Отправить назад

Используйте эту команду для отображения объекта из группы многослойных объектов, чтобы вынести его на САМЫЙ задний слой.

Чтобы вынести на самый задний слой:

1. Кликните на объекте.

2. Выберите Отправить назад в меню Оформление .


Блокирование

Блокирование объектов страницы

После того как вы расположили объект (напр. текстовое поле, изображение, форма и т.п.) на нужную позицию, можете воспользоваться его блокировкой для предотвращения случайного сдвига объета с предназначенного для него места.

Для блокирования объекта:

1. Кликните на объекте.

2. Выберите команду Блокировать из меню Правка .

3. Наведите мышку на объект, он обозначен значком блокировки ( [image] ).

Для разблокирования объекта:

1. Кликните на заблокированном объекте.

2. Выберите команду Разблокировать из меню Правка .

Примечание: Можно воспользоваться командой Блокировать все/Разблокировать все, которая применяется ко всем объектам на странице.


Создание сайта: последовательность действий

Создание сайта: обзор

Этот урок покажет вам, как создать свой веб-сайт. Самый обычный метод создания сайта при помощи Web Page Maker - это создавать и редактировать веб-странички на вашем локальном диске, а затем отправить их на удалённый веб-сервер, где они станут общедоступными.

Есть два способа создания сайта. Можно воспользоваться шаблонами Web Page Maker'а либо начать с чистой страницы и перетащить или вставить необходимые объекты на рабочее пространство веб-странички. На этом уроке вы узнаете, как начать с нуля.

Для создания веб-сайта необходимо:

1. Создать веб-страницы, добавить содержимое, установить их свойства (см. Создание веб-страниц).

2. Задать гиперссылки (см. Ссылки на странички).

3. Просмотреть и опубликовать сайт (см. Предпросмотр и публикация).


Создание сайта с помощью шаблона

Шаблоны - это уже настроенные, спроектированные веб-сайты, содержащие многочисленные связанные между собой веб-страницы. Web Page Maker предоставляет вам высококачественные шаблоны самых различных типов.

Для создания веб-сайта с помощью шаблона:

1. Выберите Новый сайт из шаблона в меню Файл .

2. Выберите шаблон из списка.

3. Нажмите OK.

Примечание: Зарегистрированным пользователям мы предоставляем большее количество шаблонов.

Редактирование шаблона

При создании сайта с помощью шаблонов Web Page Maker, вы, конечно же, захотите настроить его в соответствии со своим собственным содержимым.

  • Изменение текста
    Дважды кликните по текстовому полю, появится окно Редактора текста . Введите или вставьте собственный текст, отформатируйте его с помощью кнопок в панели инструментов.
  • Изменение изображений
    Вы, безусловно, захотите заменить изображения из шаблона на свои собственные. Для этого дважды кликните по изображению и в появившемся окне укажите расположение нового рисунка на локальном диске.
  • Удаление ненужных объектов страницы
    Выделите ненужный объект и воспользуйтесь командой Удалить из меню Правка, либо нажмите кнопку Delete на клавиатуре.
  • Перекомпоновка объектов страницы
    Вы можете изменить положение объектов в шаблоне. Для этого кликните на объекте и перетащите его на новое место.
  • Изменение ссылок
    Для замены ссылок на свои собственные, кликните на объекте, содержащем ссылку, а, затем, нажмите кнопку Гиперссылка на панели инструментов.


Создание новой страницы

С помощью Web Page Maker'а вы можете создать веб-сайт, содержащий любое угодное вам количество веб-страниц. Каждый сайт начинается с первой страницы, так что - поехали!

Запустите Web Page Maker, вы можете воспользоваться стартовой страницей по умолчанию. Web Page Maker всегда называет первую страницу index . Это очень важно, т.к. первая страница вашего веб-сайта, домашняя страница, должна называться index.

За дополнительной информацией обратитесь к разделам справки ниже:

  • Свойства страницы
  • Создание второй страницы
  • Сохранение документа


Свойства страницы

Вы можете задать большое количество свойств для страницы, включая её заголовок, цвет фона и т.д. Дважды кликните левой (или один раз правой) кнопкой мыши на любом ПУСТОМ месте веб-страницы - на на объекте! - для открытия диалога Свойств страницы . В этом диалоговом окне имеются пять вкладок: Общие, Фон, Внешний вид, Дополнительно и Заголовок.

Различные свойства страницы, такие как заголовок (название), автор, ключевые слова и описания могут быть заданы во вкладке Общие .
  • Заголовок
    Определяет название документа, оно появляется в строке заголовка браузера (в самом верху).
  • Автор
    Определяет имя автора документа, либо другую информацию, связанную с авторскими правами.
  • Ключевые слова
    Можно вводить слова, разделяя их запятой. Эти слова используются поисковыми машинами (напр. Google, Yandex и т.п.), которые идентифицируют документ, как относящийся к той или иной категории либо согласно запросу пользователя.
  • Описание
    Здесь могут быть заданы краткое описание содержания документа или его назначение. Эта информация также используется поисковыми машинами интернета.

Нажмите вкладку Фони выберите фоновый рисунок для вашей страницы. Также можно задать фоновую музыку, которая будет звучать при просмотре гостем вашей веб-странички.

Чтобы добавить фоновый рисунок:

  1. Выберите изображение на локальном диске или, по желанию, добавьте изображение из папки Фонов Web Page Maker'а.
  2. Нажмите OK.

Зафиксированный фон: эта опция закрепит фоновый рисунок таким образом, что он не будет прокручиваться при просмотре страницы. Зафиксированный фон необходим, например, при использовании водяных знаков.

Чтобы добавить звук:
  1. Выберите звуковой файл на локальном диске.
  2. Отметьте флажок Зацикливать, если вы хотите, чтобы музыка постоянно звучала при просмотре вашей страницы.
  3. Нажмите OK.

Нажмите на вкладку Внешний вид, вверху вы можете настроить, как ваша страничка будет выровнена в окне браузера. Большинство веб-страниц выровнены по левому краю (слева) и по верху. Другие хорошо смотрятся отцентрированными (выберите По центру), однако, браузеры Netscape не поддерживают выравнивание по центру.

Набор символов

Браузеры используют набор символов (т.н."кодировка"), чтобы определить, как должен отображаться документ (в какой кодировке). По умолчанию, браузеры могут отображать текст, используя западный набор символов (ISO-8859-1).

Для русскоязычных пользователей рекомендуется выставлять кодировку Windows-1251. (Прим. переводчика).

На вкладке Дополнительно, можно задать эффект перехода, который будет отображаться при входе гостей на вашу страничку. (Эти эффекты работают только в браузере Internet Explorer.)

  • Событие
    Выберите, когда эффект должен сработать. Можно задать различные эффекты для каждого из 4-х событий.
  • Эффект
    Выбор типа эффекта из выпадающего списка.
  • Длительность
    Определяет продолжительность эффекта перехода в секундах.

Вкладка Заголовок используется для ввода прочей информации в секцию заголовка текущей странички. Сюда вы можете ввести различные CSS, JavaScript, и т.д. Обратите внимание на правильность кода! WPM за неё ответственность не несёт.


Создание второй страницы

На этом уроке вы сможете создать вторую страницу для вашего веб-сайта; позже вы их свяжете при помощи гиперссылок.

Есть несколько путей создания второй странички:

  • Для создания пустой странички:

1. Нажмите кнопку Добавить новую страницу в панели Содержание сайта с правой стороны экрана. (Чтобы скрыть или отобразить панель, нажмите F8.)

2. Появится новый пустой файл. По умолчанию Web Page Maker назовёт его "page2".

Вы также можете создать вторую страницу, сделав копию первой.

  • Для создания копии первой страницы (index):

1. Нажмите кнопку Клонировать страницу в панели Содержание сайта с правой стороны экрана. (Чтобы скрыть или отобразить панель, нажмите F8.)

2. Появится копия этого файла. По умолчанию Web Page Maker назовёт его "page2". Удалите содержимое, которое не должно находиться на этой странице и добавьте новое.

Для переименования веб-страницы:

1. Выберите стрницу, которую вы хотите переименовать в панели Содержание сайта .

2. Кликните правой на имени файла и нажмите Переименовать страницу.

3. Введите новое имя страницы.

Примечание: Имена файлов должны содержать только буквы, цифры и знаки подчёркивания - никаких пробелов . Старайтесь в именах страниц не использовать заглавные буквы.

Теперь на вашем сайте уже есть две страницы, и вам следует создать между ними гиперссылки. См. соответствующий раздел ниже:

  • Ссылка на свой сайт


Удаление страницы

Для удаления созданной страницы:

1. Выберите страницу, которую вы хотите удалить в панели Содержание сайта .

2. Нажмите кнопку Удалить выбранную страницу в панели инструментов.

3. Нажмите OK .

Примечание: это действие не может быть отменено!.


Сохранение документа

С помощью этой команды вы можете сохранить активный документ. Диалог "Сохранить как " позволит вам сохранить документ под другим именем.

Чтобы сохранить ваш сайт :

1. Выберите"Сохранить" из меню Файл .

2. Появится диалоговое окно "Сохранить как ". Введите имя вашего сайта в соответствующее окно (без расширения).

3. Нажмите кнопку Сохранить . Расширение (.wss) будет добавлено автоматически.

  • Имя файла Выберите любое, какое вам по вкусу.
  • Тип файла
    При сохранении файла вы должны оставить формат .wss для дальнейшего редактирования.

Примечание: эта команда сохраняет текущий сайт в файл .wss. Это значит, что все странички вашего сайта сохранены в один единый файл. Чтобы получить формат Html, используйте встроенную функцию публикации, программа автоматически преобразует эти страницы в формат .html. Опубликованные страницы всегда в формате .html.

См. соответствующий раздел:

  • Резервное копирование


Резервное копирование

Резервное копирование ваших файлов

Важность резервного копирования нельзя недооценивать! Время от времени мы получаем письма от наших пользователей, которые потеряли все данные на жёстком диске вследствие вирусной атаки или от других несчастных случаев. Не нужно и говорить, что подобное событие может быть ужасно неприятным, если вы не выполнили резервное копирование ваших данных.

Какие файлы нужно зарезервировать?

Чтобы сохранить файл для повторного редактирования в Web Page Maker, вам необходимо сохранить файл .wss, а также изображения и другие внешние файлы, ипользованные в вашем веб-сайте. Файл .wss не содержит изображения или звуковые файлы, он лишь включает в себя ссылки на эти файлы. По этой причине мы настоятельно рекомендуем резервировать также и файлы рисунов, и файлы изображений.

К счастью, Web Page Maker предоставляет вам уникальную возможность лёгкого и быстрого копирования ваших файлов .

Как сделать резервную копию?

Следуйте указанной ниже инструкции:

1. Выберите Файл -> "Сохранить как резервную копию ".

2. Появится диалог "Сохранить как ". Выберите папку, куда вы сохраните резервную копию.

3. Нажмите кнопку Сохранить .Web Page Maker создаст файл .wss и папку с изображениями, содержащую все ваши файлы.

4. Выберите файл .wss и папку с изображениями, клик правой -> Копировать.

5. Теперь, в Моём компьютере, вы можете выбрать диск, куда хотели бы поместить файлы и с помощью команды Вставить расположить их там. Что намного легче сделать с помощью Total Commander :)) (Прим. переводчика).

Также неплохо было бы сохранить копии файлов на внешнем носителе или на USB-флэшке.


Добавление текста

Вы можете добавлять текст на вашу страничку. Текстовый редактор Web Page Maker'а позволяет вам установить тип, размер шрифта и его цвет.

Для добавления текста:

1. Нажмите кнопку Текст в панели инструментов или выберите Вставить -> Текст.

2. После двойного клика появится текстовое поле и затем окно Текстового редактора . Наберите или вставьте нужный текст.

Для вставки символов, нажмите кнопку Добавить символ (в панели инструментов текстового редактора), таким образом вы можете вставить символы, отсутствующие на клавиатуре, напр.: c §, и т.п...

Для копирования текста из другой программы в Web Page Maker:

1. Скопируйте текст в другой программе (как в Word'е) путём его выделения и нажатием Ctrl+C на клавиатуре.

2. Переключитесь на Web Page Maker, вставьте текстовое поле.

3. Дважды кликните по появившемуся текстовому полю и вставьте в него текст нажатием Ctrl+V на клавиатуре.

Примечание: Web Page Maker не сохраняет форматирование, которое использовалось в других приложениях.

Для выбора шрифта и его размера:

1. Дважды кликните по текстовому полю.

2. В текстовом редакторе выделите текст, который хотите изменить.

3. Выберите желаемый шрифт и его размер на панели инструментов текстового редактора.

Примечание: мы полагаем, что вы используете распространённые шрифты, как-то: Arial, Verdana и Times New Roman, - которые поддерживаются большинством браузеров.

Для выбора цвета фона текстового поля:

1. Кликните правой кнопкой по текстовому полю и выберите Свойства.

2. На вкладке Цвета и границы выберите желаемый цвет фона.


Изображения

Добавление изображений

С помощью изображений ваши веб-странички становятся сбалансированней и интересней. Выбирайте картинки с жёсткого диска и добавляйте их на веб-страницы. (Также можете воспользоваться встроенной библиотекой изображений Web Page Maker'а.) Web Page Maker поддерживает следующие форматы изображений: JPG, JPEG, GIF, BMP, PNG, ICO, WMF.

Для добавления изображения на веб-страницу:

1. Нажмите кнопку Рисунок на панели инструментов.

Или, нажмите на стрелочку рядом с кнопкой Рисунок, и выберите Из библиотеки.

2. Выберите изображение на жёстком диске или в библиотеке программы.

3. Нажмите OK.

Совет: вы также можете перетаскивать изображения на веб-страницу при помощи мышки.

1. Выберите папкус изображениями.

2. Перетащите выбранный рисунок на рабочее окно Web Page Maker.

3. Рисунок появится на странице.

Для изменения размера изображения:

1. Выберите рисунок.

2. Растяните его до необходимых размеров с помощью специальных манипуляторов.

Примечание: Для сохранения пропорций изображения, воспользуйтесь угловым манипулятором.

Вы можете установить границы для рисунков. Их ширина определяется в пикселях (точках).

Для установления границ:

1. Кликните правой на изображении -> Свойства.

2. Установите ширину и цвет границы во вкладке Цвета и границы .

Для создания эскиза:

Эскиз - это просто копия большого полноразмерного изображения, изменённая до меньших размеров. Чтоб сделать эскиз вам совсем не обязательно создавать новую страницу.

1. Выберите изображение на веб-странице.

2. Измените его размер жо необходимого при помощи мышки (как это сделать, рассказывалось выше).

3. Кликните правой -> Эскиз.

Примечание: В режиме просмотра эскизы работают со всеми браузерами, за исключением IE. Однако, после публикации они будут работать вне зависимости от того, какой браузер вы используете.


Формы

Добавление форм

Вы можете добавить на веб-страницу цветные формы(прямоугольник, скругленный прямоугольник и эллипс ). Вы можете разместить цветную форму поверх другой или поместить поверх её текстовое поле.

Для добавления цветной формы :

1. Нажмите стрелку рядом с кнопкой Фигура и выберите, что именно хотите добавить.

2. С помощью мышки придайте фигуре необходимый размер.

Для придания форме постоянного или градиентного цвета:

Когда форма активна вы можете изменить её цвет при помощи кнопки Цвет на панели инструментов. Вы можете установить сплошную или градиентную заливку.

1. Выберите фигуру.

2. Нажмите стрелку рядом с кнопкой Цвет на панели инструментов.

3. Проделайте следующее:

  • Для сплошной заливки выберите нужный цвет, или нажмите Другие цвета.
  • Для градиентной заливки нажмите Способы(эффекты) заливки и выберите то, что вам по душе.

Чтобы установить границы форм:

Определите ширину границ в пикселях (точках).

1. Двойной клик -> Свойства.

2. На вкладке Цвета и границы задайте нужные параметры.


Панель навигации

Добавление панели навигации

С хорошо спроектированной панелью навигации ваш сайт будет выглядеть профессионально. Web Page Maker поможет вам создать панели навигации с разнообразными эффектами.

Для создания панели навигации:

1. Нажмите кнопку Панель навигации button on the toolbar or select Navigation bar from the Insert menu.

2. Выберите категорию и стиль панели навигации в соответствующем диалоговом окне и жмите Ок.

3. На вкладке Параметры введите текст заголовка для каждой кнопки.

4. Нажмите OK .

Для добавления новой кнопки панели навигации:

Нажмите Новая кнопка на вкладке Параметры.

Вы можете изменить шрифт и размер шрифта текста на кнопках.

Для изменения шрифта кнопок:

1. На вкладке Текст настройте необходимый вид и размер шрифта.

2. Нажмите OK.

Web Page Maker позволяет вам выбрать горизонтальное или вертикальное расположение панели навигации.

Для изменения расположения панели навигации:

1. Выберите переключатель Вертикальная полоса или Горизонтальная полосадля выбора соответствующего расположения кнопок панели навигации.

2. Click OK.

Для настройки панели навигации:

1. Нажмите вкладку Настройкав дилоговом окне панели навигации.

2. С помощью кнопки Обзор... текстового поля Исходный рисунок выберите изображение при загрузке страницы.

3. В поле При наведении мыши при помощи кнопки Обзор... укажите изображение, которое появится тогда, когда курсор мышки будет находится над рисунком.

4. (Необязательно) В поле Звук под курсором вы можете выбрать звуковой файл, который будет проигрываться, когда курсор мыши будет находиться над исходным изображением.

Вы можете задать гиперссылки для кнопок навигации как на страницы на вашем сайте, так и на другие веб-адреса или адреса email.

Для создания ссылки с кнопки на другую страницу вашего сайта :

1. Выберите имя файла кнопки навигации, которая должна быть ссылкой на страницу на вашем сайте.

Чтоб это сделать, наведите курсор мыши на текст для его выделения (с левой стороны вкладки Параметры), щёлкните по нему (обычно дважды).

2. Выберите из выпадающего списка Тип ссылки -> "Страница на моём сайте ".

3. Выберите соответствующую страницу из выпадающего списка Адрес (URL) .

4. (Необязательно) Если вы хотите, чтобы указанная страница загружалась в новом окне, выберите _blank в выпадающем списке Цель

.

Для создания ссылки с кнопки на другой сайт :

1. Выберите соответствующую кнопку.

2. Выберите Тип ссылки ->"Другой сайт ".

3. Наберите полный адрес веб-сайта в строке Адрес (URL) , например: http://forum.ru-board.com :)

4. (Необязательно) Если вы хотите, чтобы указанная страница загружалась в новом окне, выберите _blank в выпадающем списке Цель

Для создания ссылки с кнопки на e-mail:

1. Выберите соответствующую кнопку.

2. Выберите Тип ссылки -> "Email адрес ".

3. Наберите полный адрес email как показано на примере в поле Адрес (URL).

Примечание: при наборе адреса не допускайте использования пробелов!

Теперь, когда вы создали панель навигации, вы можете использовать её на всех ваших страницах. Можете скопировать её и вставить куда угодно.

Чтобы скопировать панель навигации на другую страницу на вашем сайте:

1. Выберите панель навигации на первой странице.

2. Далее Правка> Копировать.

3. Переключитесь на другую страницу.

4. Выберите Правка> Вставить.

После того как вы скопировали панель навигации на другую страницу, Web Page Maker автоматически установит её на то же место, что и на первой странице.


Таблицы

Добавление таблиц

Таблицы - это прекрасный способ отображения данных в упорядоченном виде. С помощью Web Page Maker'а вы можете создать таблицы с любым количеством строк и столбцов.

Чтобы создать таблицу:

1. Выберите меню Вставить -> Таблица...

2. Установите в диалоговом окне Новая таблица количество колонок и столбцов.

3. Нажмите OK .

Для добавления информации в ячейку:

1. В редакторе таблиц кликните внутри ячейки.

2. Наберите или вставьте текст в ячейку.

Для выравнивания текста в ячейке(ах):

1. Поместите курсор внутрь ячейки, содержащей текст, который вы хотите выровнять.

2. Кликните кнопку "Свойства ячейки" на панели редактора или в контекстном меню. Выберите горизонтальное или вертикальное выравнивание.

3. Нажмите OK .

Чтобы вставить колонку или строку в таблицу:

1. В редакторе таблиц поместите курсор внутрь ячейки, в которую вы хотите добавить строки или колонки.

2. Нажмите Вставка строк или столбцов.. на панели инструментов или в контекстном меню.

3. В диалоговом окне Вставка строк или столбцов выберите, что именно вы хотите вставить - столбцы или колонки, а также позицию вставки - до или после строки или колонки с курсором.

4. Новая строка или колонка будет добавлена к странице.

Для удаления колонки или строки:

1. В редакторе таблиц поместите курсор внутрь ячейки, в которую вы хотите удалить.

2. Нажмите Удаление строк или столбцов.. на панели инструментов или в контекстном меню.

3. В диалоговом окне Delete Row or Columns (не переведено, к сожалению ), определите, что именно вы хотите удалить - столбцы или колонки, а также до или после позиции курсора.

4. Нажмите OK.

Чтобы разбить ячейки:

1. Выберите в редакторе таблиц ячейку, которая должна быть разбита.

2. Нажмите Разбить ячейки... на панели инструментов или в контекстном меню.

3. В диалоговом окне Split Cell (не переведено, к сожалению ), определите - разбить ячейки на столбцы или на строки, и установите, соответственно их количество.

4. Нажмите OK.

Для объдинения ячеек:

1. Выберите в редакторе таблиц ячейки, которые вы хотите объдинить.

2. Нажмите Объединить ячейки на панели инструментов или в контекстном меню.

Вы можете задать цвет фона для всей таблицы. Если вы применили фоновый цвет для таблицы, для строки и для ячейки одновременно, то цвет фона ячейки будет первичным и станет таковым для всей таблицы.

Для выбора цвета фона таблицы:

1. Поместите курсор внутрь таблицы.

2. Нажмите Свойства таблицы.. на панели инструментов или в контекстном меню. Задайте цвет таблицы в диалоговом окне Свойства таблицы .

3. Нажмите OK .

Для выбора цвета фона ячейки таблицы:

1. Поместите курсор внутрь таблицы.

2. Нажмите Свойства ячейки.. на панели инструментов или в контекстном меню. Задайте цвет в диалоговом окне Свойства ячейки..

3. Нажмите OK .


Аудио и видео

Добавление аудио и видео компонентов

С помощью Web Page Maker'а вы можете с лёгкостью добавить звук или видео на ваш веб-сайт.

Звук на страничку можно добавить разными способами и используя различные его форматы.

  • Настройка звукового файла в качестве фона
  • Вставка звукового файла
  • Ссылка на звуковой файл

Настройка звукового файла в качестве фона

Самый простой способ включения аудио файла на вашей страничке - это установить его в качестве фона. При посещении кем-либо вашей страницы аудио файл автоматически загрузится и начнётся его воспроизведение. У посетителя нет никакой возможности контролировать ваши файлы, вроде вкл./откл. фоновой музыки или настройки громкости воспроизведения (справедливости ради надо заметить, что с помощью специальных программ, - напр. Ad Muncher - фоновые звуки можно как раз-таки отключить - прим. перев. :)). Только один файл можно сделать фоновым.

Для установки фонового звука:

1. Дважды кликните левой или один раз правой кнопкой мыши на пустом месте веб-странички (не на объекте) для открытия диалогового окна Свойства страницы .

2. На вкладке Фон , выберите аудио файл на вашем жёстком диске.

Примечание : при публикации звуковой файл автоматически загрузится на удалённый сервер.

Вставка звукового файла

При вставке аудио файлов в веб-страницу вы предоставляете посетителю возможность регулирования воспроизведения файла - звук вкл.\выкл., громкость и т.п. Можно также вставить более одного файла на каждую страницу. Файлы будут проигрываться одним из проигрывателей, установленнном на ПК посетителя вашей странички.

Для вставки аудио файла на веб-страницу:

1. Выберите Вставить > Объект > Аудио...

2. Выберите звуковой файл .

3. Появится имя файла. Учтите, что в рабочем окне программы звуковой файл проигрываться не будет.

4. Выберите Файл > Просмотр в браузере .

Примечание : при публикации звуковой файл автоматически загрузится на удалённый сервер.

Ссылка на звуковой файл

Ссылка на звуковой файл - это простой и эффективный способ добавления звука на вашу веб-страничку. Если у вас есть, напр. mp3 файл, вы можете просто создать на него гиперссылку. При посещении вашего сайта гость может нажать на ссылку и, при желании, воспроизвести или загрузить аудио файл.

Для вставки аудио файла, который может быть загружен пользователем:

1. Выберите текст или изображение, которые будут использоваться в качестве ссылки.

2. Нажмите кнопку Гиперссылка .

3. Выберите (Чистое поле) в выпадающем списке Тип ссылки в диалоге Гиперссылки.

4. Введите в строку адреса имя файла и расширение, напр. myfile.mp3

Примечание: вам необходимо воспользоваться сторонней FTP-программой для загрузки аудио файла по ссылке на ваш веб-сайт.

Существуют два основных способа добавления видео на вашу страничку. Вы можете вставить видео файл, либо сделать на него ссылку.

Чтобы вставить видео файл:

1. Выберите Вставить > Объект > Window Media Video... (avi файл) или Real Media Video... (rm или ram файлы).

2. Выберите видео файл на вашем ПК.

3.Появится имя файла. Учтите, что в рабочем окне программы видео файл проигрываться не будет.

4. Выберите Файл > Просмотр в браузере .

Примечание : при публикации видео файл автоматически загрузится на удалённый сервер.

Чтобы создать ссылку на видео файл:

1. Выберите текст или изображение, которые будут использоваться в качестве ссылки на видео файл.

2. Нажмите кнопку Гиперссылка .

3. Выберите (Чистое поле) в выпадающем списке Тип ссылки в диалоге Гиперссылки.

4. Введите в строку адреса имя файла и расширение, напр., myfile.avi

Примечание: вам необходимо воспользоваться сторонней FTP-программой для загрузки аудио файла по ссылке на ваш веб-сайт.


Флэш

Добавление флэш роликов

С помощью Web Page Maker'а вы можете добавлять флэш ролики на веб-страницы. В веб-документ необходимо вставлять файлы *.swf, а не *.fla.

Чтобы добавить флэш ролик (.swf):

1. Выберите Вставить > Флэшка...

2. Выберите нужный ролик (.swf), первый кадр которого появится в рабочем окне.

Примечание: флэш ролики не воспроизводятся в рабочем окне программы.

3. Выберите Файл > Просмотр в браузере .

Можно установить прозрачный фон для флэш ролика.

Чтобы установить прозрачный фон:

1. Выберите ролик, кликните правой кнопкой мышки, затем Свойства.

2. Установите "WMODE" на "прозрач.".


Изменяющийся рисунок - эффект rollover

Добавление изменяющихся рисунков

Вы можете вставлять изменяющиеся рисунки на веб-страничку. Изменяющийся рисунок (rollover) - это изображение, которое изменяется при просмотре в браузере, когда на него наводится указатель мыши.

Прежде чем начать, подготовьте одну или несколько пар изображений для эффекта rollover. Эффект rollover создаётся при помощи двух файлов изображений: первого (отображается сразу при загрузке страницы) и второго (появляется при наведении на первое изображение указателя мыши). При использовании эффекта rollover оба изображения должны быть одинакового размера; если их размеры не совпадают, Web Page Maker автоматически изменит размеры второго изображения для соответствия первому.

Для создания эффекта rollover :

1. Выберите Вставить > Эффект rollover.

2. Появится соответствующий диалог, заполните поля.

(1) В текстовом поле Исходный рисунок укажите первое изображение.

(2) В поле При наведении укажите второе изображение.

(3) (Не обязательно) в поле Звук под курсором укажите звуковой файл, который будет проигрываться при наведении курсора на изображение.

(4) (Не обязательно) В поле Всплыв. текст введите текст, описывающий изображение.

(5) Нажмите кнопку Гиперссылка в нижнем левом углу и задайте ссылку для изображения.

Примечание: если вы не зададите гиперссылку, Web Page Maker добавит "нулевую ссылку" (#) в исходный код HTML, которой будет присвоен порядок смены изображений. Если вы удалите "нулевую ссылку", эффект rollover не будет больше работать.

(6) Нажмите OK .

Вы сможете просмотреть эффект rollover в окне предпросмотра, наведя курсор на исходное изображение.


Прокрутка текста

Добавление прокручивающегося текста

Прокручивающийся текст (иначе называемый "marquee ") это особый html код, который позволяет вам сделать текст ДВИЖИМЫМ. Это отличный способ привлечь внимание к вашему веб-сайту.

Чтобы вставить marquee:

1. Выберите Вставить> Бегущая строка.

2. Дважды кликните по диалоговому окну marquee , появится окно Редактора текста . Теперь просто введите текст, который должен прокручиваться на вашей страничке, задайте тип и размер шрифта, цвет текста.

3. Кликните правой по окошку marquee, выберите Свойства, на вкладке Бегущая строка задайте соответствующие вашему вкусу параметры бегущей строки.

Примечание: прокручивающийся текст поддерживается только Microsoft Internet Explorer. (как сказать: у меня и в Опере прекрасно работает... прим. перев.)


Кодировка

Аттрибут "кодировка " показывает, каким образом будет кодирована информация перед отправлением.

Браузер автоматически кодирует информацию в зависимости от зараннее заданного аттрибута кодирования. Кодировка преобразует специальные нетекстовые символы, которые могут при передаче отображаться либо набором непонятных закорючек (при неверно заданной кодировке), либо нормальным образом, так что браузер при получении информации её легко опознает. Кодировка также вставляет разделители между блоками информации.

Чаще всего вам можно даже не задумываться над типом кодирования. В этом случае будет выбрана кодировка по умолчанию.

Тип кодирования по умолчанию, это:

Тип кодирования = application/x-www-form-urlencoded

Если форма включает в себя отправку файлов, вам необходим следующий тип кодирования:

Тип кодирования = multipart/form-data

И, наконец, если вы используете mailto:link , тело вашего email-текста будет менее спутанным при использовании кодировки text/plain


Что такое формы?

Формы предназначены для сбора информации, разработаны они для получения информационных сообщений, введённых посетителями либо для динамического отображения данных посетителям вашего сайта. Посетители заполняют форму, и/или что-либо выбирают, а затем нажимают кнопку.

Для того, чтобы с информацией что-либо было сделано, её нужно куда-нибудь или кому-нибудь отправить. Пользователь вводит данные в поля формы и отправляет их на веб-сервер, где они обрабатываются Cтандартным интерфейсом обмена данных (CGI).

На самом деле данные из формы (а не саму форму) обрабатывает серверная программа, обычно CGI. Формы только получают или отображают данные. Однако, формы требуют один необходимый аттрибут, ACTION, означающий URL (веб-адрес) CGI скрипта, который обрабатывает форму и посылает ответ.


Составляющие форм

Составляющие форм - это определённые объекты, предназначенные для ввода данных пользователями. Введённые данные передаются веб-серверу и обрабатываются CGI для дальнейших операций. Каждый объект форм являет собой элемент, который обладает различным набором функций, связанный с другими элементами форм.

Типы элементов форм :

1. Однострочное текстовое поле: используется для ввода посетителем небольшого количества текстовой информации.

2. Многострочное текстовое поле: используется для ввода посетителем большего количества информации, чем может вместить однострочное текстовое поле.

3.Флажок: используется для того, чтобы посетитель выбрал или снял выбор с какой-либо опции формы.

4. Радио-кнопка: используется для выбора посетителем только одного элемента из некоторого количества оных.

5. Выпадающий список: используется для выбора посетителем элемента из списка.

6. Кнопка: используется для того, чтобы посетитель подтвердил информацию, заполненную в других объектах форм, очистил поле форм или отправил введённые данные на веб-сервер.

7. Кнопка-изображение: используется для получения координирующей информации о позиции нажатия кнопок мыши. (хоть убейте, не знаю, как это правильнее перевести - прим. перев. :))

8. Скрытое поле формы: используется для отправки значения на веб-сервер, при этом сохраняя форму невидимой посетителям сайта (Скрытое поле формы невидимо для посетителей сайта).


Создание форм

Чтобы создать форму:

1. Выберите в меню Вставить > Форма > Форма .

2. Двойной клик для установки свойств формы в появившемся окне на вкладке Форма1.

Действие определяет адрес URL, где находится скрипт, обрабатывающий информацию из формы. Например:

mailto:support@webpage-maker.com или http://www.mysite.com/cgi-bin/myform.cgi

Поле Метод определяет собственно сам метод, которым будут обработаны данные формы:

Выберите Post для скрытия информации скрипта в адресе URL. Либо Get для её отображения.

Затем установите Тип кодирования , т.е. как будет отослана информация. Например: text/plain

После того как вы добавили форму на веб-страницу, вы можете начать вставлять Элементы формы . Т.е. поля, которые будут заполнять посетители сайта. Элементы, относящиеся к данной конкретной форме будут добавлены автоматически.

Мы рекомендуем вам вначале вставить саму форму, а потом добавлять элементы.


Однострочное текстовое поле

Добавление однострочного текстового поля

Это поле служит для ввода текста посетителем сайта.

Чтобы добавить однострочное текстовое поле:

1. Выберите Вставить > Форма > Текстовое поле из одной строки

2. Двойной клик для установления Имени и Исходного значения . Если исходное значение не установлено, текстовое поле будет пустым.

3. Выберите Тип ввода. По умолчанию - это обычный текст.

  • Выберите Стандарт. текст (подходит в большинстве случаев).
  • Если вы выбрали Пароль , тогда каждый введённый символ будет отображаться в виде звёздочки (*).
  • Если вы выберите Имя файла, то сразу за текстовым полем появится кнопка Обзора файлов, нажав на которую посетитель сможет выбрать файл на своём жёстком диске, и имя выбранного файла будет автоматически отображено в текстовом поле.

4. Нажмите OK.

5. Если вы желаете добавить действие, выберите Вставить > Форма > Форма. Затем назначьте элемент относительно к выбранной форме.

Примечание: если вы сначала добавили форму, а затем элементы, тогда элементы формы будут добавлены автоматически.

Вы можете изменять размеры текстового поля. Также можете изменять его свойства в соответствующем диалоге Свойств, который появится при двойном клике на выбранном вами текстовом поле.


Многострочное текстовое поле

Добавление многострочного текстового поля

Текстовое поле с прокруткой позволит посетителям вводить больше текста, чем это можно сделать в однострочное поле.

Чтобы добавить многострочное текстовое поле:

1. Выберите Вставить > Форма > Многострочное текстовое поле

2. Двойной клик для установления Имени и Исходного значения . Если исходное значение не установлено, текстовое поле будет пустым.

3. Нажмите OK.

4. Если вы желаете добавить действие, выберите Вставить > Форма > Форма. Затем назначьте элемент относительно к выбранной форме.

Примечание: если вы сначала добавили форму, а затем элементы, тогда элементы формы будут добавлены автоматически.

Вы можете изменять размеры текстового поля. Также можете изменять его свойства в соответствующем диалоге Свойств, который появится при двойном клике на выбранном вами текстовом поле.


Флажок

Добавление флажка

С помощью флажков посетитель вашего сайта может выбрать одно или несколько значений из их группы, либо включить или отключить какую-либо единственную опцию. В отличие от радио-кнопок, флажками можно пометить одновременно несколько полей.

Чтобы добавить флажок:

1. Выберите Вставить > Форма > Флажок

2. Двойной клик для установки имени и значения.

3. Определите Начальное состояние . Это значит, будет ли флажок уже отмечен при загрузке страницы в браузере.

4. Нажмите OK.

5. Если вы хотите добавить действие, выберите Вставить > Форма > Форма. Затем добавьте объект к форме.

Примечание: если вы сначала добавили форму, а затем элементы, тогда элементы формы будут добавлены автоматически.


Радио-кнопки

Добавление радио-кнопок (переключателей)

Радио-кнопки обычно используются в группах. С помощью радио-кнопок пользователь может пометить лишь один объект из группы. Все кнопки в группе должны иметь одинаковое имя и содержать различные значения.

Чтобы добавить радио-кнопки:

1. Выберите Вставить > Форма > Переключатель

2. Двойной клик для определения Имени и Значения.

3. Установите, должен ли переключатель быть изначально помечен (Выбрано - Не выбрано).

4. Нажмите OK.

5. Если вы хотите добавить действие, выберите Вставить > Форма > Форма . Затем добавьте объект к форме.

Примечание: если вы сначала добавили форму, а затем элементы, тогда элементы формы будут добавлены автоматически.

Вы можете создать различные взаимодействия радио-кнопок в форме, но обратите внимание на тот факт, что каждый набор переключателей должен иметь уникальное имя, и все радио-кнопки какой-либо группы должны называться одинаково.


Выпадающий список

Добавление выпадающего списка

С помощью выпадающего(раскрывающегося) списка посетитель сайта может сделать выбор в пользу того или иного объекта из списка представленных.

Для добавления выпадающего списка:

1. Выберите Вставить > Форма > Раскрывающийся список

2. Нажмите Добавить.

3. В появившемся диалоговом окне, введите Текст и Значение и нажмите ОК.

  • Текст: это собственно сам текст, который появится при просмотре списка в браузере.
  • Значение: это значение, которое будет отправлено на сервер, когда посетитель сайта выберет тот или иной элемент из списка.

4. Если вы хотите добавить действие, выберите Вставить > Форма > Форма . Затем добавьте объект к форме.

Примечание: если вы сначала добавили форму, а затем элементы, тогда элементы формы будут добавлены автоматически.


Кнопка

Добавление кнопки

С помощью кнопки посетитель сайта отправляет на веб-сервер команду, относящуюся к данной форме (напр. "Отправить"). Иногда кнопка используется в сочетании с Java скриптами, которые выполняют определённые функции при нажатии кнопки.

Чтобы добавить кнопку:

1. Выберите Вставить > Форма> Кнопка

2. Двойной клик, а затем введите иимя для определения кнопки в поле Имя.

3. В поле Значение, введите названиекнопки. Если тип кнопк Отправка, это значение также будет отправлено на сервер.

4. Выберите Тип кнопки.

  • Если вы выберите Отправка , кнопка отправит данные формы на сервер.
  • Если вы выберите Сброс , форма будет очищена.
  • Если вы выберите Общее, кнопка сама по себе ничего не будет делать, необходимо присоединить действие JavaScript'а, который и выполнит необходимую функцию при нажатии кнопки.

5. Нажмите OK.

6. Если вы хотите добавить действие, выберите Вставить > Форма > Форма . Затем добавьте объект к форме.

Примечание: если вы сначала добавили форму, а затем элементы, тогда элементы формы будут добавлены автоматически.


Кнопка-изображение

Добавление кнопки-изображения

Данный объект производит действие подобное нажатию кнопки Отправка. Как и обычная кнопка Отправить , при её нажатии будет послана определённая информация на сервер.

Чтобы добавить кнопку-изображение:

1. Выберите Вставка > Форма > Кнопка-изображение

2. Выберите рисунок на жёстком диске, и нажмите открыть.

3. Дважды кликните по рисунку, введите его название в поле Имя.

4. Нажмите OK.

5. Если вы хотите добавить действие , выберите Вставить > Форма > Форма . Затем добавьте объект к форме.

Примечание: если вы сначала добавили форму, а затем элементы, тогда элементы формы будут добавлены автоматически.


Скрытая форма

Добавление скрытой формы

Скрытое поле используется для хранения статичного значения, которое отправляется на сервер вместе с остальной информацией формы. Однако, оно невидимо посетителю. Скрытое поле можно использовать, например, чтобы отправить имя документа, содержащего форму.

Для добавления формы скрытого поля:

1. Выберите Вставка > Форма > Форма скрытого поля

2. Двойной клик, затем введите Имя формы

3. Введите Значение, которое будет отправлено на сервер.

4. Нажмите OK.

В рабочем окне скрытая форма будет обозначена рисунком:

Но этот рисунок не будет отображаться в браузере или при Предварительном просмотре.


Пример- форма Email

Это пример стандартной Email - формы. По умолчанию, когда посетитель заполняет форму и нажимает кнопку Отправить, браузер сообщает ему об отправленни данных по email и автоматически их отправляет (не запуская при этом почтовый клиент).

Для добавления email формы:

1. Выберите Вставка > Форма > Пример- форма Email.

2. Появится сама форма. Дважды кликните на ней, замените immortal223@gmail.com :-) тем адресом, который вам нужен.

3. Нажмите Ok.

Если вам нужна более мощная email форма, соответствующая вашим потребностям, вам необходим серверный скрипт, наподобие FormMail.cgi либо другой у провайдера. Вам следует связаться с администратором хостинга, чтобы узнать, как получить доступ к серверным программам и, вообще, имеются ли на вашем хостинге таковые.


Добавление HTML-кода

Чтобы добавить HTML код:

1. Выберите HTML код или скрипт код ... в меню Вставка .

2. Наберите или вставьте HTML в окне HTML редактора .

Можно воспользоваться стандартными клавишами Ctrl+V на клавиатуре.

3. Нажмите OK.

4. Удостоверьтесь, что объект вашего кода достаточен по размеру для полного соответствия с содержимим HTML. Вы можете растянуть поле кода до необходимого размера с помощью мышки.

Примечание: если вы использовали нестандартный или неправильный фрагмент кода, Web Page Maker его не сможет автоматически исправить.


Фреймы

Добавление фрейма

Фрейм - это такая конструкция, которая вставляет какой-либо документ в HTML-документ таким образом, что добавленные данные отображаются в отдельном подокне браузера.

Для добавления фрейма:

1. Выберите Вставка > Фрейм.

2. Можете воспользоваться кнопкой "Обзор " для поиска добавляемого файла.

Либо вставьте страницу из тех, что уже есть на вашем сайте, нажав переключатель 'Внутренняя страница' и выбрав соответствующую из списка.


Стили гиперссылок

Если вы не производили никаких манипуляций с отображением ссылок на веб-страничке, они обычно будут выглядеть примерно так: текст синего цвета (или около этого), подчёркнутый . Подобное отображение используется браузером по умолчанию. Но если такой дизайн ссылок вас не устраивает, вы можете воспользоваться нижеприведённым рецептом. Читайте далее, если вы хотите:

  • Установить собственный цвет текста для ссылок
  • Избавиться от подчёркивания
  • Задать цвет фона ссылкам
  • Определить ваш собственный формат отображения ссылок в зависимости от того, посещали ли вы их, наводите ли вы мышь на ссылку, или, даже, нажимали ли вы на неё.

Вы можете использовать каскадную таблицу стилей (CSS) для управления отображением текста на вашей странице. Установить цвет, шрифт, фон и многое другое. Придайте совершенно новый вид вашей страничке!

Чтобы добавить таблицу стилей:

1. В меню Формат нажмите Стили гиперссылок...

2. Нажмите"Добавить" в диалоговом окне Стили гиперссылок. Появится диалог Добавить стиль .

3. Выберите стиль ссылки на свой вкус и нажмите "OK".

4. Дважды кликните по текстовому полю на вашей страничке. Выберите курсором нужный вам текст. Воспользуйтесь кнопкой "Задать гиперссылку" в панели инструментов Текстового редактора. Появится диалог "Гиперссылка ".

5. Выберите созданный вами стиль из выпадающего меню в нижней части диалогового окна "Гиперссылка ".

Примечание: первым в списке указывается стиль по умолчанию. Свой созданный стиль вы можете найти чуть ниже в этом же списке.

Этот инструмент работает в браузерах Internet Explorer и Netscape 6X. Netscape 4X не полностью поддерживают CSS.


Обзор ссылок

Гиперссылка - это один из элементов веб-страницы (обычно это слово, кнопка, или изображение), который "указывает" на другую веб-страницу. Когда посетитель нажимает на ссылку в браузере, происходит переход на эту страницу, которая может располагаться как на том же сайте, так и на любом другом сайте в интернете.

URL

Каждая веб-страница имеет свой уникальный адрес, т.н. Унифицированный указатель ресурса (URL ). Для веб-документов формат URL такой:

http://domain/directory/.../document.html

Например, http://www.webpage-maker.com/v2/index.html, "www.webpage-maker.com" - это домен, "v2" - это каталог, а "index.html" - это имя документа. Зачастую имя документа пропускается. В таком случае URL указывает на исходный документ в определённой папке или домене, который обычно называется "index.html".

URL-ы используются в основном для указания ссылок на документы, находящиеся на других сайтах. Для получения более подробной информации по URL-ам, посетите World Wide Web Consortium website - www.w3.org/Addressing/ (англ.)

Существуют два основных вида гиперссылок, которые используются в веб-документах: Абсолютные и Относительные.

  • Абсолютные пути

Абсолютные пути представляют собой полные ссылки на указанный документ, включая используемый протокол (обычно http:// для веб-страниц). Например, http://www.webpage-maker.com/index.html - это абсолютный путь.

  • Относительные пути

Относительная ссылка указывает на документ, как на некий ярлык, основанный на расположении целевого документа относительно к тому, который содержит ссылку (прим. переводчика : ну и завернул же я! :)). Пример относительной ссылки - "index.html".

Когда вы создаёте локальную ссылку (ссылку с одной страницы на другую в пределах одного сайта), вам, обычно, не нужно указывать весь URL документа, на который вы даёте ссылку; вместо этого, вы указываете относительный путь от текущего документа или от корневой папки сайта.

Примечание: не смотря на то, что вы можете также указывать абсолютные пути для локальных ссылок (на документы на этом же самом сайте), этот метод не рекомендуется - если вы переместите свой сайт на другой домен, все ваши ссылки, привязанные к абсолютным путям, будут нарушены. Использование относительных путей для локальных ссылок даст вам больший простор для манёвров, если вы захотите переместить файлы на вашем сайте.

Стартовая (домашняя) страничка должна называться index

Домашняя страничка - это первая страница, которую видит посетитель при заходе на ваш сайт. Почти во всех сайтах она носит имя "index.html ". Некоторые сайты используют другие названия, однако большинство сайтов позволят вам использовать любое из названий по умолчанию.

Всё-таки очень важно, чтобы первая (стартовая или домашняя) страничка вашего сайта называлась index.


Редактор ссылок

Web Page Maker - редактор сылок

С помощью Web Page Maker'а очень легко добавлять ссылки на ваши веб-странички. Редактор ссылок используется для всех операций со ссылками , напр. ссылка на др. страницу вашего сайта, ссылка на страницу другого сайта, ссылка на файл или ссылка на email. В Редакторе ссылок существует 5 разделов: Тип (ссылки), URL, Закладка, Цель и Заголовок.

Тип

Выберите тип ссылки из выпадающего списка.

  • Страница на моём сайте: ссылка на страницу на вашем сайте.

При нажатии на стрелку рядом с окошком выпадающего списка, будет отображён список всех страниц, имеющихся на вашем сайте, т.о. вы можете выбрать любую из них.

Когда вы даёте ссылку на страницу на том же сайте, программа автоматически сохранит ссылку и произведёт все необходимые изменения. Например, если вы изменили название страницы, все ссылки на неё также будут обновлены. Если вы удалили страницу, то и ссылки на неё также будут удалены.

  • Другой сайт: ссылка на другой веб-сайт.

При выборе этого типа ссылки, наберите в текстовом поле соответствующий URL - http:// .

  • Адрес Email: ссылка на почтовый адрес.

При выборе этого типа ссылки, наберите в текстовом поле после mailto: соответствуюший адрес. В этом случае будет запущена почтовая программа на компьютере посетителя вашего сайта.

  • Адрес FTP: передача файлов может быть вызвана FTP-ссылкой. Это специально согласованный метод передачи файлов между компьютерами в интернете. Адрес FTP начинается с "ftp://", в отличие от веб-адресов, которые начинаются с "http:// ".
  • (пусто): ссылка на другой тип гиперссылок.

Выбирайте этот тип для ввода ваших собственных вариантов ссылок. Эта настройка рекомендуется только для опытных пользователей.

URL

Список URL будет содержать все ссылки, выбранные в строке Тип . При выборе"Страница на моём сайте ", будет отображён список всех страниц вашего сайта. Если вы ссылаетесь на другой сайт, вам следует выбрать тип ссылки " Другой сайт " и ввести полный адрес (URL).

Закладка

Закладка обычно используется для создания локальной ссылки на определённый участок вашей веб-страницы. Типичный пример закладки - это использование ссылки "Наверх ", которая перенесёт посетителя с нижней части страницы к её началу, в случае нажатия на эту ссылку. Для получения более подробной информации, см. Создание закладок.

Цель

Эта опция определяет, каким образом ссылка будет открываться в окне браузера. Эти фреймы называются _blank, _parent, _self, и _top.

  • _blank Ссылка откроется в новом окне.
  • _parent Ссылка откроется в родительском окне (при наличии нескольких уровней). Соответствует _top, если на странице фреймы только первого уровня.
  • _self Ссылка откроется в текущем фрейме/окне. Это значение по умолчанию, так что обычно вам не нужно её указывать.
  • _top Ссылка очистит все существующие фреймы и откроет URL как самый верхний документ.

Заголовок

Этот пункт содержит информацию о ссылке, которая будет отображена при наведении на ссылку указателя мышки, при этом перехода по ссылке не произойдёт.


Ссылка на свой сайт

Ссылка на другую страницу вашего сайта

Создание ссылок между страницами - это необходимая вещь при создании собственного сайта. Без ссылок ваш сайт не будет функционировать, т.к. не будет возможности совершать переход с одной страницы на другую.

Прежде всего, вам необходимо создать ещё одну страницу на своём сайте. Если вы последовательно прочитали нашу справку, значет вы уже создали дополнительные страницы; на этом уроке вы научитесь связывать ссылками созданные вами страницы.

Для создания ссылки на другую страницу вашего сайта:

1. Выделите текст или изображение на "первой" странице.

  • Для выделения изображения - кликните по нему один раз.
  • Для выделения текста, кликните дважды по текстовому полю, и с помощью курсора выберите необходимый вам диапазон текста в Текстовом редакторе.

2. Нажмите кнопку "Задать гиперссылку" на панели инструментов. Появится диалог "Гиперссылка ".

3. Выберите "Страница на моём сайте " из выпадающего меню Тип.

4. Нажмите на стрелочку в выпадающем списке URL , появится список всех имеющихся на вашем сайте страниц. Выберите одну из них.

5. (Не обязательно) Если вы хотите, чтобы указанная вами страница загружалась в новом окне, выберите _blank, нажав на область Цель.

6. (Не обязательно) Если вы хотите озаглавить ссылку, введите её описание в текстовое поле Заголовок . При просмотре в браузере, когда вы наведёте указатель мышки на ссылку, вы увидите небольшую всплывающую подсказку жёлтого цвета с кратким описанием ссылки.

Примечание: В рабочем окне программы ссылки не функционируют, они работают только в браузере. Чтобы проверить правильность ссылок, вам необходимо запустить предпросмотр страницы в браузере. Подробнее о предпросмотре см. Здесь.


Ссылка на другой сайт

Ссылка на другой веб-сайт

Для создания ссылки на другой сайт:

1. Выделите текст или изображение, которое должно стать ссылкой.

2. Нажмите кнопку "Задать гиперссылку" на панели инструментов. Появится диалог "Гиперссылка ".

3. Выберите "Другой сайт" из выпадающего меню Тип.

4. Введите полный адрес (URL) веб-сайта после http://. Например: http://www.webpage-maker.com/new.html

5. (Не обязательно) Если вы хотите, чтобы указанная вами страница загружалась в новом окне, выберите _blank, нажав на область Цель .

6. (Не обязательно) Если вы хотите озаглавить ссылку, введите её описание в текстовое поле Заголовок . При просмотре в браузере, когда вы наведёте указатель мышки на ссылку, вы увидите небольшую всплывающую подсказку жёлтого цвета с кратким описанием ссылки.


Ссылки на закачку

Самый простой способ для предоставления закачки файла с вашего сайта - это дать прямую ссылку на него. Просто создайте ссылку на файл, а когда посетитель зайдёт на ваш сайт и кликнет по ней, откроется стандартный диалог сохранения файла и файл будет закачан на ПК посетителя.

Создание ссылки на документ PDF (например) :

1. Выделите текст или изображение, которое должно стать ссылкой.

2. Нажмите кнопку "Задать гиперссылку" на панели инструментов. Появится диалог "Гиперссылка ".

3. Выберите (пусто) из выпадающего меню Тип .

4. Введите в текстовое поле URL имя файла и его расположение. Например: myfile.pdf

5. Воспользуйтесь сторонней FTP-программой для загрузке файла на свой сервер, проследите, чтобы путь на нём был правильным, соответствующим ссылке.


Цель

Параметры цели (назначения)

Опция цель определяет то, как ссылка будет открываться в окне браузера. Исходные параметры - это _blank, _parent, _self, and _top .

_blank = ссылка откроется в новом окне

_top = ссылка очистит все существующие фреймы и откроет URL как самый верхний документ

_parent = ссылка откроется в родительском фрейме (при наличии нескольких уровней). Эквивалентна _top, если уровень лишь один

_self = ссылка откроется в текущем фрейме/окне. Это исходное значение, так что обычно его можно не указывать.

Если вы хотите, чтобы указанный вами документ открылся в новом окне браузера, просто выберите _blank и нажмите OK .


Метод

Аттрибут "метод " определяет то, как отсылается куда бы то ни было информация. Существуют два значения - метод="POST" или метод="GET", использование какого-либо из них зависит от программы назначения или оператора-функции, который должен получить информацию.

Отправление методом GET

Метод="GET" используется в том случае, если вы хотите отослать куда-либо информацию посредством адресной строки браузера. Эта строка выглядит примерно так::

http://domain.com/something.cgi?color=red&shape=round

В указанном адресе часть строки после знака вопроса - это информация, отправляемая на something.cgi. Составные блоки информации разделяются амперсандом (&) .

Методом GET можно отправить только ограниченный объём информации. Ограничение зависит от сервера, на котором расположена данная веб-страница и от сервера, на который отсылается информация. Оно может быть до 256 байт, но чаще всего 1Кб и больше.

Другой недостаток метода GET заключается в том, что отправляемая информация видна в адресной строке браузера. Порой это неважно, но в иных случаях - недопустимо.

Некоторые CGI-программы могут принимать информацию как отправленную методом GET, так и методом POST, иные же обрабатывают только GET.

Отправление методом POST

Метод="POST " - это стандартный метод отправления информации из формы к программе обработки или оператору-функции. Он используется, например, при обработке JavaScript'ов.

Этим методом можно отправить намного больше информации, чем методом GET. На данный момент большинство браузеров и веб-серверов ограничивают общий объём POST-информации до 32 Кб.

Методом POST информация не отправляется из адресной строки браузера, отправка данных невидима посетителю сайта.

Точный механизм работы метода POST знать совсем необязательно. Всё что вам нужно сделать - это указать метод, а браузер сам определит, как ему исполнить ваше указание. Вкратце же это выглядит следующим образом: в зависимости от адресата, POST-информация передаётся непосредственно браузером (напр. при отсылке к обработчику функции JavaScript) или по Интернету методом, известным как "стандартный вход" - т.е. адресат принимает информацию через исходный или стандартный канал входа ( напр. сервер для программы CGI).


Ссылки на email

Ссылки на адрес электронной почты

С помощью Web Page Maker вы можете добавить ссылку на свой адрес электронной почты на вашей странице, таким образом посетители могут легко послать вам сообщения. Эта функция открывает новое пустое почтовое окно (используется почтовая программа, связанная с браузером пользователя).

Для создания почтовой ссылки:

1. Выделите текст или изображение.

2. Нажмите кнопку "Задать гиперссылку" на панели инструментов. Появится окно "Гиперссылка ".

3. Выберите в выпадающем списке " Адрес Email ".

4. После слова mailto: наберите полный адрес и нажмите OK. Например: mailto:support@webpage-maker.com

Примечание: Не допускайте появления пробела после двоеточия, следующего за словом mailto .


Аттрибут action

Actions

Аттрибут "action" определяет получателя отправленной информации. Для того, чтобы обработать информацию, её нужно куда-либо отправить. Обработчиками информации могут выступать CGI-программы, операторы-обработчики JavaScript'ов, ссылки mailto:, и даже веб-страницы (указывающие браузеру загружать страницы по определённому адресу).

Обработка ссылок mailto:

Чтобы отправить уже заполненную информацию на почтовую программу посетителя, воспользуйтесь следующим:

action=mailto:name@domain.com

Если вы хотите указать тему письма:

action=mailto:name@domain.com?subject=My%20Subject

(Вместо пробелов при указании названия темы подставьте "%20".)

Обратите внимание, что не все браузеры распознают ссылки mailto:.

Отправка данных на CGI-программу

Если информация отправлена на CGI-программу, расположенную на том же домене, что и веб-страница, содержащая форму, то аттрибут action может содержать как абсолютный, так и относительный адрес. Относительный URL выглядит примерно таким образом:

action=/cgi-bin/something.cgi

Если информация отправлена на CGI-программу, расположенную на другом домене, адрес должен быть абсолютным:

action=http://domain.com/cgi-bin/something.cgi

Отправка данных на обработчика JavaScript

В этом случае аттрибут action должен выглядеть примерно так:

action=javascript:SomeFunction()

Либо же, аттрибут action может быть заменён особым аттрибутом JavaScript "onclick":

onclick=return SomeFunction()

Если необходимо отправить информацию на обработчика JavaScript и на CGI-программу, тогда следует указать и аттрибут action, и аттрибут onclick.

Отправка данных на веб-страницу

Для отправления информации формы на другую веб-страницу так, что браузер откроет страницу по новому адресу, введите:

action=http://newdomain.com/page.html


Закладки

Создание ссылок с закладками

Закладка указывает на пометку на вашей странице. Она обычно используется для создания локальной ссылки на определённое место веб-страницы. Типичный пример подобной ссылки - это закладка top, которая переносит посетителя с низа веб-страницы к её началу, при нажатии на top.

Закладка - это невидимая пометка, которую можно оставить на любом месте веб-документа и использовать в качестве гиперссылки. Установка ссылки на закладку позволит вам перейти на то место страницы, куда указывает закладка.

Для создания ссылки с закладкой на той же странице:

1. Выберите Вставка > Закладка

2. Появится маленький значок закладки ( [image] ). Поместите его на соответствующее место вашей страницы.

Можно использовать исходное имя (bookmark1) либо переименовать его, как вам удобнее. Для этого просто щёлкните дважды по символу.

3. Выберите текст или изображение, для которого создаёте закладку.

4. Нажмите кнопку "Гиперссылка" в панели инструментов. Появится диалог "Гиперссылка ".

5. В выпадающем списке URL нажмите на стрелку и выберите текущую страницу.

6. Выберите нужную закладку в выпадающем списке Закладка .

7. Нажмите OK.

Для создания ссылки с закладкой на другую страницу:

1. На другой странице добавьте закладку нажатием Закладка в меню Вставка

2. Появится маленький значок закладки ( [image] ). Поместите его на соответствующее место вашей страницы. .

Можно использовать исходное имя (bookmark1) либо переименовать его, как вам удобнее. Для этого просто щёлкните дважды по символу.

3. Перейдите на первую страницу, выберите текст или изображение которые должны стать ссылкой для закладки на второй странице.

4. Нажмите кнопку "Гиперссылка" в панели инструментов. Появится диалог "Гиперссылка ".

5. В выпадающем списке URL нажмите на стрелку и выберите соответствующую страницу.

6. Введите имя закладке в дилоговом окне. Например:закладка1. Значок # вводить не нужно.

7. Нажмите ОК


Просмотор страниц в браузере

Просмотр страниц в браузере

В рабочем окне программы вы получите лишь самые общие сведения того, как будет выглядеть созданная вами cтраница в браузере, а единственный способ увидеть истинный вид страницы - это просмотреть её в браузере. "Просмотр в браузере" покажет вам, как будет выглядеть веб-страница после опубликования её в интернете. Вы можете в любое время просмотреть её в вашем браузере по умолчанию. При этом даже не нужно предварительно сохранять документ.

Для просмотра веб-страниц в браузере:

1. Нажмите кнопку Просмотр (F5) в панели инструментов.

2. По окончанию тестирования просто закройте страницу в браузере.

Примечание: при просмотре ваших страниц в виде HTML вы можете проверить работоспособность всех локальных ссылок на своём сайте, просто пройдитесь по ссылкам и удостоверьтесь в том, что все они работают.


О публикации

Что такое публикация?

После того, как вы создали и отредактировали свой собственный сайт вам необходимо разместить его на веб-сервере. "Загрузка" созданных вами файлов на веб-сервер называется Публикацией.

Перед публикацией сайта

Сначала вам необходимо выбрать хостинг. Хостинг - это компания, которая размещает ваши страницы на своём веб-сервере.

Бывают платные и бесплатные хостинги. Существует большое количество фирм, предлагающих свой сервис за умеренную годовую или помесячную оплату. Вы легко можете выбрать ту из них, которая более всего соответствует вашим требованиям. Есть также немало бесплатных хостингов, которые, однако, будут размещать рекламные баннеры на вашем сайте (Если вы создаёте сайт для компании, то лучше избегать подобных хостингов).

После выбора подходящего хостинга вам необходимо зайти на его веб-сайт, зарегистрироваться там и активировать свою учётную запись. В результате вы получите имя пользователя, пароль , адрес веб-сервера и имя удалённой папки. Это необходимая информация для публикации ваших веб-страниц.

Публикация с помощью Web Page Maker'а

Web Page Maker публикует сайты на ЛЮБОЙ хостинг, использующий стандартные настройки FTP. В программу встроен специальный модуль, так что вам не нужно пользоваться сторонними FTP клиентами.

Web Page Maker автоматически преобразует ваши страницы в HTML и отправит их либо в локальную папку на вашем компьютере, либо на указанный вами веб-сервер.

Подробнее о публикации смотрите в соответствующих разделах справки:

  • Настройки публикации
  • Размещение в локальной папке


Настройки

Настройки публикации

Если вы не знакомы с FTP (File Transfer Protocol), эти настройки могут для вас показаться немного сложными. К счастью, данную операцию вам нужно проделать всего один раз. Программа сохранит ваши настройки, так что вы сможете просто нажимать кнопку Опубликовать и сайт будет обновлён согласно той информации, что вы раннее ввели. Web Page Maker также включает в себя возможность создания различных профилей публикации для нескольких пользователей.

Для настройки информации публикации:

1. Нажмите кнопку Опубликовать (F4) в панели инструментов или выберите команду Опубликовать в меню Файл .

2. Нажмите кнопку Новый...в окне Публикация . Появится диалог настройки удалённого сайта.

3. Введите Имя профиля в окне настроек. Это может быть любое имя.

4. Заполните необходимую информацию:
  • Хостинг -- Введите адрес FTP сервера, на который вы будете загружать файлы. Она может быть разной, но в большинстве случаев - это имя домена или IP - адрес. http:// and ftp:// вводить НЕ НУЖНО. Более подробную информацию вы можете узнать на веб-сайте вашего хостинга.
  • Веб-папка -- Введите путь к папке на FTP сервере, в которой будут храниться ваши документы. В большинстве случаев эту строку можно оставить пустой. Более подробную информацию вы можете узнать на веб-сайте вашего хостинга.
  • Пользователь -- Введите имя пользователя. Это имя, под которым вы входите на сервер.
  • Пароль-- Введите пароль, предоставленный вам администрацией хостинга для доступа на FTP сервер.
  • Порт -- Введите номер порта, используемый для соединения с FTP. Исходное значение, 21, подходит в большинстве случаев.
  • Пассивный режим -- Поставьте здесь галочку, если сервер использует брандмауэр или роутер, требующий пассивный режим.

Если вы не знаете процедуру подключения или не обладаете необходимой информацией для настройки вашего FTP соединения, свяжитесь со службой технической поддержки вашего хостинга.

5. После введения всей необходимой информациии нажмите OK.

Потом вы заметите, что в список добавлен новый сервер . Чтобы добавить ещё один сервер нажмите опять кнопку Новый... Чтобы изменить профиль, выберите его и нажмите кнопку Изменить... Чтобы удалить профиль, выделите его и нажмите кнопку Удалить .

После настройки информации публикации, вы можете загрузить свои файлы на сервер. См. раздел ниже:

  • Начало процесса публикации

Примечание от переводчика: ниже приводится настройка FTP-соединения одного из популярнейших бесплатных российских хостингов - narod.ru:


Начало процесса публикации

После того как вы настроили информацию публикации и соединились с сервером - самое время начать процесс публикации .

Для начала процесса публикации:

1. Выберите имя профиля из списка. Нажмите кнопку Опубликовать внизу диалогового окна "Публикация".

2. Когда публикация завершена, вы увидите сообщение Publishing Completed! в окне состояния публикации.

3. Нажмите Выход.


Важные параметры

Важные параметры публикации

В этом разделе будут подробно объяснены настройки второй вкладки -- "Параметры страницы" в диалоговом окне Публикация . Здесь вы можете настроить папку для сохранения изображений вашего сайта, страницы, которые вы хотите опубликовать, и прочие настройки для загрузки или обновления вашего сайта.

  • Файлы и расширения

В этом выпадающем списке отображаются имена и расширения страниц, которые будут созданы. Вы можете выбрать другое имя для каждой страницы и задать другое расширение.

  • Подпапка для рисунков

В этом списке вы можете ввести имя для папки, в которой будут сохранены все изображения с вашего сайта. Если вы оставите это поле пустым, то все изображения будут сохранены в папке с файлами HTML.

Если вы не знаете, что сюда вводить, просто оставьте это поле пустым.

  • Диапазон страницы

Выберите страницы, которые вы собираетесь опубликовать. Можно выбрать текущую страницу или все страницы вашего сайта. По умолчанию установлено "Опубликовать все на моём сайте".

Настройка публикации

Когда вы впервые публикуете свой веб-сайт, вам следует загрузить на сервер все файлы (включая html, изображения, и т.д.).

Если выбрано "Опубликовать только html файлы", вы сможете загрузить только файлы html, которые были изменены с момента последней публикации (не будут опубликованы изображения, аудио-файлы, и т.п.). Обычно эта опция используется, когда вы изменили лишь текст в своих файлах.

  • Авторезервирование wss файла при публикации

Когда выбрана эта опция, программа создаст резервный файл вашего сайта на сервере - файл с расширением *.wss.

Этот файл будет скопирован в ту же самую папку, где сохранён index .html. Также вы можете скачать ваш *.wss файл с сервера при помощи менеджера закачек (например Download Master). Например, если вы назвали свой файл "mysite.wss", то он будет доступен по этому адресу: http://www.mysitename.com/mysite.wss.

Вы можете отключить эту функцию. Однако, по вполне очевидным причинам, мы не рекомендуем это делать. Время от времени мы получаем письма от наших пользователей, которые потеряли все свои данные на жёстком диске вследствие каких-дибо незапланированных действий или несчастного случая. Не приходится и говорить о том, что подобное событие очень неприятно для тех пользователей, которые не сделали резервного копирования данных на своём винчестере.


Публикация в локальной папке

Не смотря на то, что самый простой способ опубликовать сайт - это публикация при помощи встроенного в программу мастера, вы также можете воспользоваться, другой FTP-программой. Если вы хотите использовать сторонний FTP-клиент, то для начала необходимо преобразовать созданные вами файлы в html-формат, в указанную зараннее папку.

Публикация в локальную папку:

1. Нажмите кнопку Опубликовать (F4) на панели инструментов или воспользуйтесь соответствующей коммандой в меню Файл .

2. Нажмите радио-кнопку Локальная папка во вкладке Адресат в окне Публикация .

3. Нажмите Обзор и выберите папку.

4. Нажмите Опубликовать.

Примечание: По умолчанию все страницы вашего сайта будут экспортированы в выбранную вами папку.


ЧаВо о публикации

1. Я успешно загрузил сайт на сервер, но когда пытаюсь просмотреть страницы в браузере, то постоянно выскакивает ошибка: "HTTP 404--File Not Found", - почему?

2. Я опубликовал свою домашнюю страницу, но не вижу её.

3. Я создал страницу и вставил изображения в неё. При предпросмотре все рисунки на месте. Однако, после публикации на сервере и при просмотре в браузере вместо изображений показываются "красные крестики", - в чём дело?

4. Я не могу загрузить свой сайт на сервер, постоянно получаю одну и ту же ошибку: "Невозможно подключиться к серверу".

5. Я перепробовал всё и по-прежнему не могу опубликовать свой сайт. Так в чём же дело?

6. Как опубликовать мой сайт на America Online (AOL)?

7. Как опубликовать мой сайт на бесплатном хостинге Yahoo! Geocities?

8. Я опубликовал сайт на хостинге YAHOO! с помощью испытательной версии Web Page Maker'а и в нижней части веб-страниц отображается баннер, при этом пропадают некоторые мои изображения. Как мне избавиться от этой проблемы?

9. Как обновить уже опубликованную веб-страницу?

10. Я обновил веб-страницу на сервере, а в браузере по-прежнему отображается старая.

11. Как я могу управлять своими файлами на сервере и, в частности, удалить их?

12. Возможно ли за один раз опубликовать все страницы моего сайта?

13. Вы предоставляете услуги хостинга?

14. Я не нашёл ответа на свою вопрос, что мне делать?

1. Я успешно загрузил сайт на сервер, но когда пытаюсь просмотреть страницы в браузере, то постоянно выскакивает ошибка: "HTTP 404--File Not Found", - почему?

Эта ошибка возникает по двум причинам: либо Вы неправильно назвали стартовую страницу, либо опубликовали веб-документы не в ту папку на сервере.

Возможная причина #1: Неверно названная стартовая страница

Стартовая страница сайта (домашняя) - это страница, которую вы видите введя основной адрес сайта в адресную строку браузера. Например, "http://www.webpage-maker.com". Если вы не указываете в строке имя документа, веб-сервер пытается загрузить стартовую страницу. Большинство хостингов требуют, чтобы ваша стартовая страница называлась index.html или index.htm . Следовательно, домашняя страница всегда должна называться index.

Возможная причина #2: Документы загружены не в ту удалённую папку

Документы вашего сайта хранятся в отдельной папке на сервере. Для того, чтобы страницы были видны посетителям, вам следует загрузить их в "правильную" папку ну сервере. Если вы не знаете, какая папка правильная, оставьте путь к ней пустым. Если этот способ не сработал, свяжитесь с администрацией хостинга.

Как только вы получите всю необходимую информацию, заполните поле Удалённая папка в диалоговом окне Настроек удалённого соединения. И затем просто перезагрузите свой сайт на сервер.

2. Я опубликовал свою домашнюю страницу, но не вижу её

Если вы не видите домашнюю страницу, проверьте в Стартовой панели (справой стороны экрана), называется ли она index. Если домашняя страница называется как-то иначе, переименуйте её в index .

3. Я создал страницу и вставил изображения в неё. При предпросмотре все рисунки на месте. Однако, после публикации на сервере и при просмотре в браузере вместо изображений показываются "красные крестики", - в чём дело ?

Сначала проверьте имена изображений. Некоторые серверы не воспринимают в названиях файлов заглавные буквы, пробелы и прочие специальные символы. Убедитесь, что имена изображений не содержат пробелы (myfile.gif, а не my file.gif), и что расширения написаны в строчном формате (image.gif правильно, а image.GIF - неправильно)

Далее следует проверить размер изображений. Если он слишком большой, может возникнуть тайм-аут при передаче файлов. Вам следует уменьшить размер файлов, или использовать другой FTP-клиент.

4. Я не могу загрузить свой сайт на сервер, постоянно получаю одну и ту же ошибку: "Невозможно подключиться к серверу"

Эту проблему могут вызвать несколько причин.

1) Наиболее вероятная причина - это то, что включён ваш файрвол, который и блокирует процесс передачи файлов. В зависимости от файрвола, программа может ждать, пока не произойдёт подключение, или же завершить передачу, так и не начав её. Если вы используете Windows XP (sp2), обратите внимание, что XP файрвол может быть вклёчён по умолчанию. Также проверьте, не включён ли какой-либо сторонний брандмауэр.

В этом случае, вы должны разрешить доступ программе в интернет. Нажмите сюда! Можно также запретить ей вообще выходить в сеть, но мы не рекомендуем это делать.

2) Другая возможная причина это то, что вы заполняя форму ввели данные вроде этих: ftp://yourhost.com, но ftp:// вводить НЕ НУЖНО.

3) Ещё одна причина может состоять в том, что невозможно установить соединение с хостингом. Проверьте ваши сетевые настройки, убедись, что здесь всё в порядке.

5. Я перепробовал всё и по-прежнему не могу опубликовать свой сайт. Так в чём же дело?

Причина вашей неудачи при публикации сайта может заключаться в том, что ваш хостинг использует нестандартный FTP-сервис. Web Page Maker публикует сайт на любой хост, который использует стандарнтные настройки FTP. Попобруйте опубликовать на другой хостинг. Или же, экспортируйте созданные страницы в файлы .html (Нажмите кнопку Опубликовать (F4) на панели инструментов и пометьте флажок Локальная папка), затем воспользуйтесь сторонней FTP-программой (например, Ftp Explorer - он бесплатен) для загрузки файлов на веб-сервер.

Если вы используете БЕСПЛАТНЫЙ хостинг, возможно, что у вас просто нет прямого FTP доступа к сайту. Многие бесплатные хостинги используют онлайновые файловые менеджеры, доступ к которым возможен прямо из браузера. В этом случае вам необходимо преобразовать созданные страницы в формат html и разместить их в какую-либо папку на жёстком диске. А уж потом при помощи онлайнового менеджера загрузить ВСЕ эти файлы.

6. Как опубликовать мой сайт на America Online (AOL)?

Для этого вам необходимо произвести следующие настройки.

1) Войти в AOL.

2) В Web Page Maker'е, выбрать кнопку Опубликовать (F4) в панели инструментов либо в меню Файл .

3) Нажать Новый... во вкладке Информация о сайте .

4) Ввести следующие настройки нового сайта:

Хостинг: members.aol.com
Веб-папка: Ваше_имя_в_AOL (логин для входа в AOL)
Пользователь: anonymous
Пароль: Ваше имя в AOL (логин для входа в AOL), далее "@aol.com." Например, если ваш логин "vasia_pupkin," введите "vasia_pupkin@aol.com."

5) Нажмите Опубликовать.

Если не получится опубликовать при помощи Web Page Maker, постарайтесь воспользоваться AOL FTP клиентом.

7. Как опубликовать мой сайт на бесплатном хостинге Yahoo! Geocities?

В этом случае вам также нужно для начала опубликовать свой сайт на жёстком диске, а затем при помощи онлайнового файлового менеджера загрузить его на хостинг Yahoo! Geocities .

8. Я опубликовал сайт на хостинге YAHOO! с помощью испытательной версии Web Page Maker'а и в нижней части веб-страниц отображается баннер, при этом пропадают некоторые мои изображения. Как мне избавиться от этой проблемы?

Нажмите на вкладку "Параметры страницы" в диалоговом окне "Публикация", снимите флажок "Авторезервирование .wss файла ".

9. Как обновить уже опубликованную веб-страницу?

Чтобы обновить страницу вам нужно изменить исходную, а затем опубликовать её снова на сайте.

10. Я обновил веб-страницу на сервере, а в браузере по-прежнему отображается старая.

Ваш браузер кэширует страницы, которые вы раннее посещали. Чтобы обойти это, если вы используете Internet Explorer, удерживайте нажатой клавишу CTRL и нажмите одновременно кнопку обновить страницу.

11. Как я могу управлять своими файлами на сервере и, в частности, удалить их?

В принципе, вы можете сделать это в Internet Explorer. Введите в адресной строке бразера:

ftp://yourusername:yourpassword@yourserver.com и увидите папки на сервере, в которых хранятся ваши html файлы.

Также можно воспользоваться FTP клиентом (а ещё проще - Total Commander'ом - прим. переводчика) .

12. Возможно ли за один раз опубликовать все страницы моего сайта?

Да. Программа настроена по умолчанию именно на полную публикацию вашего сайта.

13. Вы предоставляете услуги хостинга?

Нет.

14. Я не нашёл ответа на свой вопрос, что мне делать?

Если вы не нашли ответа на поставленный вопрос в этом ЧаВо, пришлите нам письмо по следующему адресу: support@webpage-maker.com , в котором опишите вкратце возникшую проблему.


ЧаВо по WPM

Общие вопросы по Web Page Maker'у

1. Как сделать ссылку на всплывающее окно?

2. Как создать эскиз, который ссылается на полное изображение?

3. Как мне добавить к картинкам это маленькое всплывающее жёлтое сообщение?

4. Как изменить цвет ссылок при наведении на них курсора мыши?

5. Я добавил таблицу стилей согласно инструкции, но когда я хочу установить новый стиль, в выпадающем списке его нет.

6. Как мне настроить собственную панель навигации?

7. Как мне разрешить людям загружать файлы с моего сайта?

8. Хотелось бы знать, возможно ли поместить видеофайл на мой сайт, так что люди могли б его просмотреть при посещении сайта.

9. Как установить фоновое изображение на веб-страницу?

10. Как изменить размер страницы?

11. На моём ПК сайт смотрится хорошо (при разрешении экрана 1024*768), но на других компьютерах (разрешение 800*600) появляется горизонтальная прокрутка для просмотра всей страницы.

12. Я хочу "отцентрировать" страницу. Как мне это сделать?

13. При сохранении веб-страницы какой формат мне использовать?

14. Резервную копию каких файлов мне необходимо делать?

15. Я повторно открыл мой сайт в Web Page Maker'е, почему исчезли некоторые изображения?

16. Нужно ли мне экспортировать все файлы в html, чтобы загрузить их на сервер?

17. Как импортировать HTML страницу?

18. Где я могу найти дополнительные шаблоны к программе?

19. Я загрузил из интернета несколько шаблонов, могу ли я их использовать в Web Page Maker'е?

20. Можно ли создавать фреймы в Web Page Maker'е?

21. Как встроить счётчик в страницу?

22. Можно ли изменить кодировку, например Кириллица / Иврит/ и т.п.?

23. Я создал веб-страницу и использовал некоторые шрифты, установленные на моём ПК. Однако когда на мой сайт заходят люди, то не у всех отображаются эти шрифты. Следует ли мне использовать универсальные шрифты для всех компьютеров?

24. Я не нашёл ответа на свой вопрос, что мне делать?

1. Как сделать ссылку на всплывающее окно?

Вы можете разместить скрипт-код прямо в поле ввода адреса диалогового окна "Гиперссылка ". Приведённый ниже пример указывает на всплывающее окно размером 620 на 420 пикселей.

javascript:void(window.open('page2.html','','resizable=no,scrollbars=yes,status=yes,width=620,height=420'))

Также, заметьте, что page2.html указывает на страницу вашего сайта. Если вы хотите сделать ссылку на другой сайт, то укажите его полный адрес: http://www.thesite.com .

2. Как создать эскиз, который ссылается на полное изображение?

Эскиз - это просто копия полного изображения, изменённая для уменьшения размера файла. Вам не нужно создавать новую страницу для того, чтобы сделать эскиз. Просто вставьте изображение, измените его размер и затем в контекстном меню нажмите Эскиз.

3. Как мне добавить к картинкам это маленькое всплывающее жёлтое сообщение?

При просмотре веб-сайта в браузере, когда вы наводите курсор на изображение, вы можете видеть небольшое жёлтое окошко с кратким описанием рисунка, которое как бы всплывает под курсором. Вы можете добавить свой собственный текст к рисунку, выполнив следующую последовательность шагов:

(1) Нажмите Вставка > Изображение.

(2) Кликните правой кнопкой на вставленном изображении, выберите Свойства.

(3) Во вкладке Рисунок , введите своё описание в поле Подсказка .

4. Как изменить цвет ссылок при наведении на них курсора мыши?

Вы можете изменить цвет ссылок при наведении на них курсора, указав соответствующий стиль сылок. Проделайте следующие шаги:

(1) Нажмите Формат > Стили гиперссылок... Появится соответствующее диалоговое окно.

(2) Нажмите Добавить. Появится окно "Добавить стиль ".

(3) Настройте свой стиль на четырёх вкладках.

(4) При указании ссылки в Текстовом редакторе вам следует выбрать стиль из выпадающего списка Стиль ссылки, который находится в нижней части диалогового окна "Гиперссылка ".

5. Я добавил таблицу стилей согласно инструкции, но когда я хочу установить новый стиль, в выпадающем списке его нет.

Ссылка внутри Текстового редактора назначает соответствующую ссылку на текстовую строку, тогда как вы, нажимая на кнопку ссылки в панели инструментов, назначаете её на текстовое поле, следовательно в данном случае Стиль ссылки не отобразится.

Ссылки нужно добавлять внутри текстового поля. (Дважды кликнув по текстовому полю, введите текст, выделите его, затем добавьте гиперссылку, нажав на соответствующую кнопку в панели инструментов Текстового редактора.)

6. Как мне настроить собственную панель навигации?

1) Нажмите на кнопку Панель навигации, выберите Панель навигации из меню Вставка .

2) Выберите категорию с левой стороны окна Выбор стиля панели навигации , подберите подходящий стиль панели, нажмите ОК.

3) Выберите вкладку Настройка .

4) В поле Исходный рисунок нажмите Обзор.. и выберите изображение, которое появится при загрузке страницы.

5) В поле При наведении нажмите Обзор.. и выберите изображение, которое появится при наведении курсора на исходный рисунок.

6) (Необязательно) В поле Звук под курсором нажмите Обзор.. и выберите звуковой файл, который будет проигрываться при наведении курсора на исходное изображение.

7. Как мне разрешить людям загружать файлы с моего сайта?

Самый простой способ сделать файл доступным для загрузки с вашего сайта - это указать на него ссылкой. Просто создайте гиперссылку на файл, и когда посетитель зайдёт на ваш сайт, он нажмёт на эту ссылку. Далее он сможет выбрать то что ему необходимо: открыть файл или закачать его.

Например, у вас есть файл PDF, создайте на него простую ссылку . Если вы введёте в адресной строке только имя файла (напр. myfile.pdf ), имейте в виду, что сам файл должен располагаться в той же папке, где и страница, с которой вы делаете ссылку на файл. В противном случае вам необходимо указать абсолютный путь (например http://www.myserver.com/folder/myfile.pdf).

Используйте стороннюю FTP-программу для загрузки файла, на который вы сделали ссылку, на сервер.

8. Хотелось бы знать, возможно ли поместить видеофайл на мой сайт, так что люди могли б его просмотреть при посещении сайта.

При добавлении видеофайла на веб-страницу вы предоставляете посетителю возможность регулировать воспроизведение, громкость звука и т.п. Можно добавить не только один файл, но и несколько. Файлы будут проиграны при помощи видеопроигрывателя, установленного на компьютере пользователя.

Чтобы добавить видеофайл выберите Вставка > Объект > Window Media Video (avi файл) или Real Media Video (rm или ram файл). Выберите файл на жёстком диске. Появится имя файла. Воспользуйтесь Файл> Просмотр в браузере для предпросмотра.

9. Как установить на веб-страницу фоновое изображение ?

Двойной клик или клик правой кнопкой на любом пустом месте веб-страницы (не на объекте). Появится диалоговое окно Свойства страницы. Нажмите на вкладку Фон, кликните по кнопке Обзор и укажите путь к вашему изображению.

10. Как изменить размер (длину) страницы?

Размер веб-страницы автоматически определяется границами расположенных на ней объектов. Нет особого ограничения, насколько "длинной" может быть созданная вами страница.

Для удлинения (расширения) страницы просто переместите объекты далее вниз или в сторону.

11. На моём ПК сайт смотрится хорошо (при разрешении экрана 1024*768), но на других компьютерах (разрешение 800*600) появляется горизонтальная прокрутка для просмотра всей страницы.

То, как отображается содержимое вашей страницы целиком и полностью зависит от размера монитора, размера окна браузера и от разрешения экрана. Если вы создаёте веб-страницы на 17-дюймовом мониторе, вам следует просмотреть остаток страницы при помощи горизонтальной прокрутки на 15-дюймовом экране.

В настоящее время не существует способа форматирования страниц, чтобы они полностью соответствовали ширине окна браузера. Мы рекомендуем вам при построении сайта исходить из меньших размеров. Наиболее распространённый размер в настоящее время - 800*600. Мы также рекомендуем выравнивать содержимое страниц по центру, таким образом страница будет корректнее отображаться при просмотре и на больших экранах. Чтобы отцентрировать страницу, дважды кликните на любом пустом месте веб-страницы (не на объекте), выберите вкладку Внешний вид, и отметьте Выравнивание -> По центру .

12. Я хочу "отцентрировать" страницу. Как мне это сделать?

Смотрите ответ в предыдущем вопросе.

13. При сохранении веб-страницы какой формат мне использовать?

Если вы собираетесь редактировать свои веб-страницы в будущем, вам следует сохранить их как .wss файл (Web Page Maker распознаёт в настоящее время только этот тип файлов). Программа автоматически преобразует все страницы вашего сайта в файлы .html и загрузит их на веб-сервер, который вы указали раннее в настройках.

Для того, чтобы иметь возможность в будущем открыть и редактировать созданные страницы, вам необходимо сохранить их в формате .wss . Чтобы проделать эту операцию, поступите следующим образом:

1) ВыберитеФайл > Сохранить.

2) Появится окно "Сохранить как ". Введите новое имя для сохраняемого файла (без расширения).

3) Нажмите Сохранить. Расширение (.wss ) будет добавлено автоматически.

14. Резервную копию каких файлов мне необходимо делать?

Для возможности последующего редактирования созданных вами страниц вы должны создать резервную копию файла .wss и всех изображений, либо других внешних файлов, которые вы использовалия при создании своего сайта. Файл .wss содержит всю информацию о ваших веб-страницах. Обратите внимание, что он не содержит в себе изображения или звуковые файлы, а только лишь ссылки на таковые на вашем жёстком диске. По этой причине мы также рекомендуем вам делать резервную копию всех рисунков и аудиофайлов, которые вы использовали на своём сайте.

К счастью, Web Page Maker предоставляет простейший способ создания копии вашего сайта . Просто нажмите в меню Файл "Сохранить как резервную копию.. ", Web Page Maker создаст .wss файл и папку image, в которой будут размещены все внешние файлы.

15. Я повторно открыл мой сайт в Web Page Maker'е, почему исчезли некоторые изображения?

Если вы переместили или удалили изображения с жёсткого диска, Web Page Maker может их просто не найти при повторном открытии вашего сайта. Вместо картинок вы увидите белые "квадратики" с красными крестиками . Это может произойти также, если вы переименовали файлы.

Чтобы исправить рисунок, дважды кликните на "квадратике" с отсутствующим изображением. Появится последнее месторасположение искомого файла. Вы можете либо указать новый путь к рисунку, либо вернуть его на прежнее место.

16. Нужно ли мне экспортировать все файлы в html, чтобы загрузить их на сервер?

Нет. Программа сама преобразует их и отправит на сервер при помощи встроенной функции публикации.

17. Как импортировать HTML страницу?

В настоящее время Web Page Maker не поддерживает возможность открытия существующей веб-страницы для дальнейшего её редактирования в среде WYSIWYG (What You See Is What You Get - досл.: "что видишь, то и получаешь",- прим. переводчика ). Всё, что вы можете сделать - это открыть html файл в любом текстовом редакторе, скопировать весь его код и вставить как скрипт-код в Web Page Maker. Но в этом случае вы не сможете редактировать страницу в среде WYSIWYG, хотя при просмотре в браузере она будет корректно отображаться.

18. Где я могу найти дополнительные шаблоны к программе?

Мы предоставляем вам полную версию программы, в которую входят дополнительные шаблоны и другие ресурсы. Все шаблоны в формате .wss созданы нашими веб-дизайнерами, они полностью бесплатны для зарегистрированных пользователей.

19. Я загрузил из интернета несколько шаблонов, могу ли я их использовать в Web Page Maker'е?

Эти шаблоны обычно совместимы с программами Adobe Golive, Dreamweaver и FrontPage. Для работы с ними вам лучше всего воспользоваться именно этими приложениями.

Либо перетащите каждый элемент шаблона по-отдельности на рабочее пространство Web Page Maker.

20. Можно ли создавать фреймы в Web Page Maker'е?

В настоящее время программа полностью не поддерживает работу с фреймами. Однако, вы можете работать с т.н. 'iFrame'. Iframe'ы предоставляют вам возможность встроить страницу в созданную раннее.

Выберите "Фрейм" из меню "Вставка ". Далее либо кнопкой Обзор найдите нужную страницу, либо выберите "внутреннюю", уже созданную вами.

21. Как встроить счётчик в страницу?

Счётчик - это специальный HTML код, который встаивается в веб-страницу. Он связан с программой на сервере, которая подсчитывает количество обращений к данной странице (сайту). Существует огромное количество веб-компаний, предоставляющих подобные бесплатные услуги. Вам нужно просто зайти на их веб-сайт, зарегистрировать бесплатный счётчик и получить соответствующий HTML код.

Чтобы добавить код счётчика на веб-страницу просто добавьте его путём вставки из меню "Html код или скрипт код ". Вы увидите пустое окно "HTML" в рабочем окне программы. Опубликовав страницу на сервере, вы увидите как работает счётчик.

22. Можно ли изменить кодировку, например Кириллица / Иврит/ и т.п.?

Двойной клик или клик правой кнопкой по пустому месту страницы (не по объекту). Откроется окно Свойства страницы . Внизу во вкладке Внешний вид, выберите из выпадающего списка Набор символов пункт "Пользовательский", и введите вашу кодировку, напримердля кириллицы - windows-1251 .

23. Я создал веб-страницу и использовал некоторые шрифты, установленные на моём ПК. Однако когда на мой сайт заходят люди, то не у всех отображаются эти шрифты. Следует ли мне использовать универсальные шрифты для всех компьютеров?

Web Page Maker, как и большинство других Windows-приложений, опирается на операционную систему, которая и поставляет шрифты пользователю. Учтите, что если вы используете при создании своего сайта какие-нибудь специфические шрифты, то ваш сайт может некорректно отображаться на компьютере посетителя, так как на неё, возможно, не установлены эти шрифты. В этом случае браузер посетителя отобразит шрифт, назначенный по умолчанию.

Мы полагаем, что вы используете общераспространённые шрифты (напр. Arial, Verdana, и Times New Roman), которые поддерживаются большинством веб-браузеров. Либо вы можете преобразовать текст в изображение (напр. при помощи Photoshop), и затем нажать кнопку Рисунок -> Из файлов для его импортирования .

24. Я не нашёл ответа на свой вопрос, что мне делать?

В этом случае вам следует связаться с нами по адресу: support@webpage-maker.com


Настройки брандмауэра

Настройки брандмауэра под Windows XP SP2

Если вы собираетесь загрузить веб-страницы при помощи встроенного инструмента публикации, вам следует добавить Web Page Maker как исключение (доверенное приложение), таким образом брандмауэр разрешит доступ программе в интернет.

Настройка Windows Firewall (SP2) (для англ. версии):

1. Нажмите Start, затем Control Panel.

2. Далее Security Center , потом Windows Firewall.

3. Во вкладке Exceptions , нажмите Add Program.

4. В окне Add a Program , выберите Web Page Maker и нажмите OK. Появится программа, поставьте галочку в окошке напротив программы в поле Programs and Services во вкладке Exceptions .

5. Нажмите OK.

От переводчика: я не "проиллюстрировал" этот раздел русскоязычным вариантом, так как не использую встроенный в Windows брандмауэр из-за крайней его убогости :)


Как зарегистрироваться?

Web Page Maker - условно-бесплатная программа, которая предоставляется пользователям для испытания бесплатно. Цель shareware-программ - это обеспечение пользователей персональных компьютеров высококачественными приложениями по принципу "Try before you buy" (попробуй, прежде чем купи), однако для продолжения использования программы сверх оговоренного срока её необходимо приобрести.

Web Page Maker поставляется с 15-дневным испытательным сроком. Если вам понравится эта программа и вы захотите использовать её после окончания испытательного периода, вам следует оплатить её. Стоимость программы - $49.00 (49 Долларов США) . Оплата производится только один раз, а все последующие обновления бесплатны для зарегистрированных пользователей. Все пользователи после регистрации получают регистрационный код и бесплатную техническую поддержку.

Вы можете передавать эту программу друзьям и коллегам, но обязательно должны включить в пакет все файлы из оригинального дистрибутива. Предложите им, пожалуйста, зарегистрировать свои копии, если они сочтут программу полезной :)).

Как зарегистрировать Web Page Maker?

Выберите, пожалуйста, один из следующих методов оплаты регистрации:

Метод 1: Безопасная онлайн оплата по кредитной карточке

Для оплаты этим методом, нажмите, пожалуйста, "Buy Now" . После принятия вашей карточки вы получите по email подтверждение заказа. Регистрационный код будет выслан вам по электронной почте в течение 24 часов.

Если у вас возникли проблемы при онлайн-оплате, воспользуйтесь методом 2. Или же сообщите нам по адресу: support@webpage-maker.com

Метод 2: Телефон

Чтобы заказать Web Page Maker по телефону, пожалуйста, позвоните по номеру 1-877-REGSOFT (1-877-734-7638) (для международных звонков номер 770-319-2718) в течение обычного бизнес-времени. Идентификационный номер продукта (ID): 60705. Менеджер по продажам из Regsoft, Inc. спросит номер вашей карточки и предоставит всю необходимую регистрационную информацию.

Метод 3: Факс

Чтобы заказать Web Page Maker по факсу, нажмите Сюда и следуйте инструкциям по "Заказу по факсу" на появившейся веб-странице (необходимо соединение с интернетом).

Мы свяжемся с вами с подтверждением и регистрационной информацией.

Метод 4: Обычная почта

Если вы предпочитаете платить чеком, почтовым денежным переводом, или дорожным чеком, нажмите, пожалуйста, Сюда и следуйте инструкциям по "Заказу по почте" на появившейся веб-странице (необходимо соединение с интернетом).

Если у вас возникли проблемы, свяжитесь с нами по адресу: sales@webpage-maker.com

Прим. переводчика: я вот тут подумал, а надо ли вообще было переводить эту страницу? :) Подумал и решил, что последнюю я переводить точно не буду! Всем спасибо - все свободны!

P.S. Ваши замечания и предложения по поводу перевода присылайте мне на адрес immortal223@gmail.com


Untitled Document

END-USER LICENSE

SOFTWARE PRODUCT(S) IMPORTANT-READ CAREFULLY:

This Web Page Maker End-User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and Web Page Maker Software Co. LTD for the Web Page Maker software product(s) identified above. By installing, copying, or otherwise using the Web Page Maker SOFTWARE product(s) identified above, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, do not install or use the Web Page Maker SOFTWARE product(s) identified above.

1. GRANT OF LICENSE:

- Install and use. Web Page Maker grants to you the non-exclusive right to use Web Page Maker on a single computer. You may make copies of the Web Page Maker for backup and archival purposes. Web Page Maker Software Co. Ltd reserves all rights not expressly granted.

- COPYRIGHT. Web Page Maker is owned by Web Page Maker Software Co. Ltd. and is protected by copyright laws and international copyright treaty provisions, as well as other intellectual property laws and treaties. Therefore, you must treat Web Page Maker like any other copyrighted material. You may not use or copy Web Page Maker for any other purpose than what is described in this Agreement.

2. OTHER RESTRICTIONS

You may not make or distribute copies of the Software, or electronically transfer the Software from one computer to another or over a network. You may not recompile, reverse engineer, disassemble, or otherwise reduce the Software to a human-perceivable form. You may not rent, lease or sublicense the Software. You may not modify the Software or create derivative works based upon the Software.

3. TERMINATION:

Without prejudice to any other rights, Web Page Maker may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the Web Page Maker SOFTWARE product(s) identified above.

4. SUPPORT SERVICES:

Web Page Maker provides tech support services related to the Web Page Maker SOFTWARE product(s) identified above ("Support Services"). Use of Support Services is governed by Web Page Maker polices and programs described in the user manual, in online documentation, and/or other Web Page Maker-provided materials. Any supplemental software code provided to you as part of the Support Services shall be considered part of the SOFTWARE and subject to the terms and conditions of this EULA. With respect to technical information you provide to Web Page Maker as part of the Support Services, Web Page Maker may use such information for its business purposes, including for product support and development. Web Page Maker will not utilize such technical information in a form that personally identifies you.

5. NO WARRANTIES.

Web Page Maker expressly disclaims any warranty for the Web Page Maker SOFTWARE product(s) identified above. THE SOFTWARE AND ANY RELATED DOCUMENTATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OR MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. THE ENTIRE RISK ARISING OUT OF USE OR PERFORMANCE OF THE SOFTWARE PRODUCT REMAINS WITH YOU.

6. LIMITATION OF LIABILITY.

To the maximum extent permitted by applicable law, in no event shall Web Page Maker or its suppliers be liable for any special, incidental, indirect, or consequential damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use the SOFTWARE or the provision of or failure to provide Support Services, even if Web Page Maker has been advised of the possibility of such damages.